Okay, I have noticed that whenever I installed the latest version of any software and then uninstalled it(even after using purge remove command from the terminal)because it doesn't support my distro(14.04.3 LTS amd64) and then tried installing an older version of the same software which is actually supposed to work on my distro, It still installs the latest version of that software which I had previously uninstalled. Even using terminal commands to uninstall the software using a .deb file was of no help. I faced this problem while installing steam but had to reinstall my entire O.S. to install steam properly which worked properly thanks to(Steam Install Error on 14.04 Ubuntu 64bit). Now I'm facing the same problem when I tried to install intel linux graphics installer. I had accidentally installed the latest version which only supports 15.10 and therefor every time I ran the program(at times even as a superuser) It showed an error which read "Distribution not supported". The I found this(Distribution not supported error when trying to install Intel Graphics Installer on Ubuntu 14.04) and so wanted to install the older version which is actually supposed to work on my but even via terminal installation and using the correct .deb file it kept installing the latest version of it which is unsupported on my pc. So please, can anyone tell me how I can completely remove the malfunctioning version and safely install the correct version? :'(

  • 2
    What commands are you using to install software? Are you installing .deb files manually or getting software from the repositories? Please provide complete examples. – Seth Dec 21 '15 at 2:25
  • I don't think that older version for the intel installer works anymore although you could always give it a try. – mchid Dec 21 '15 at 2:49
  • Would appreciate if you mark whichever answer has helped as 'Accepted'. – Dhaval Simaria May 23 '16 at 13:58
sudo apt-get purge [package]
sudo apt-get autoclean
sudo apt-get autoremove
  • Sorry guys, sudo apt purge is fine but autoclean and autoremove need apt-get and I can't retract my reject vote on that edit. – mchid Dec 21 '15 at 3:00
  • It's: sudo apt-get --purge remove && sudo apt-get autoremove && sudo apt-get clean – ShuaibKunji May 11 '16 at 9:16
  • @ShuaibKunji whilst sudo apt-get --purge remove works too, it's legacy functionality, the newer format is sudo apt-get purge, or in newer releases, just sudo apt purge – Jeremy Davis Mar 2 '18 at 3:56

I usually use this command

sudo apt-get remove --purge {package-name}
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get clean

Hope this help you too


purge remove will remove about everything regarding the package packagename, but not the dependencies established during installation.

sudo apt-get purge --auto-remove [packagename]

This will remove the package along with the configuration files and dependencies.

For better understanding, you may refer to:

What is the correct way to completely remove an application?


You can run: sudo dpkg -P intel-linux-graphics-installer to get rid of that version.

Alternatively, this should work as well:

sudo apt-get purge intel-linux-graphics-installer

I'm not sure if the older version is still available but you can try the instructions here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.