0

After some reinstallation/configuration/partition resizing work (I really can't say where the point of failure was, but see below for details), I ended up with unity not working anymore, a situation essentially similar to this or this: login works, and then I just get a blank screen.

I've tried several things listed in those questions, like restarting various stuff, purging and reinstalling compiz, unity, and ubuntu-desktop, or deleteting their config files. Also using compizconfig-settings-manager and re-enabling the Unity-plugin didn't help (although it was disabled, in case that's relevant information).

I then just tried to install alternative desktop environments and display mangers, and that's where things started to get weird: namely, it turned out that lxde and openbox do work under both lightdm and gdm, while unity and gnome-shell don't work on either (after login, just a background image appears and nothing more).

One additional thing that sometimes happened in lxde was that an "Internal Error" box showed up, containing (among others) the following information:

Title: xorg crashed with SIGABRT in __libc_message()

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins

(but this only showed up after I already reinstalled and changed many things, so it might be related to problem or not).

Now, I have no idea where the failing is actually happening, but I suspect compiz...


What I actually was doing before this happended:

  • Installing 14.04 on a separate partition (1) from the original installation (2) (also 14.04)
  • Normal login, so the default unity, lightdm and ubuntu-desktop did work
  • Installing some programs
  • Mounting my old /home from the old installation, which is on a third partition (3), as /home for the new installation (and setting this in the new fstab)
  • Installing more stuff, and deleting some config directories/files from ~ which I thought are not needed anymore
  • At some point here, I have also used unity-tweak-tool, but only to increase the number of virtual workspaces
  • Resizing partitions (1) and (2)
  • Reboot

After the last reboot, said things happended. I don't think the partitioning stuff plays any role, but I mention it for completeness; but maybe my reusing the old /home did something weird? On the other hand, I (think I) rebooted at least once with it mounted as /home of the new install, without problems.

I also use a dual-monitor setup, but that has never caused any problems.


The question is: is there anything else I could do for getting unity back and gnome-shell work? Or should I just reinstall everything -- in which case, should I not just reuse the old /home, or would that not be a problem?

1

Probably some configuration file has gone wrong. Most applications build a default configuration if they don't find thei config directory.

Using a console save your config directories (those starting their name with a ".") into a new folder (e.g. ~/old_configs) - look what happens.

  • Wow, as simple as that. For the record: among the automatically newly created config directories were .config and .gconf, in which I now suspect the source of the problem must have lied (the rest was just .local, .ssh, .gnupg and .ICEAuthority). – phg Dec 20 '15 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.