1

I'm using Ubuntu 14.04 and 15.10 on HP ProOne 600 with Intel Graphic HD 4400.

My screen looks grainy as the picture. I am also dualbooting with Win 8.1 x64 and the screen is fine on that side.

Screenshot 1

Screenshot 2

Screenshot 3

I have tried installing Intel Graphic Driver from the 01.org site but it didn't seem to work (grainy still.) I have also tried to other linux distribution (eg. Fedora 23.10 and several other ubuntu based like xubutu and Mint) but none seemed to make any difference

When using 'nomodeset' in grub the screen seemed ok but I was stuck with 1024x768 resulution (the native res is 1920x1080) Is there anything I am missing here? Your advice will be greatly appreciated.

Thank you,

Ken

ps. below is the hardware info regarding the VGA

lshw -c video

*-display
   description: VGA compatible controller
   product: 4th Generation Core Processor Family Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:28 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)
1
  • I have the same issue and very interested in a solution. Have you made any progress? – rhobincu Feb 15 '16 at 16:43
0

I actually found a solution for this. There is a LVDS Panel Select setting in BIOS what programs the EDID which will be later read by the video chip. The default value for that setting is Auto-select or Auto-detect or something similar. In my case, setting the panel to BOS made the artifact disappear in Linux. There were two more options there: LG and Samsung, depending on the exact model of your screen, it's possible another setting will work for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.