-1

I'm trying to install GTKTerm

on my 12.04 LTS distribution. I read the INSTALL file for install the software. First I run ./configure, no errors are shown, but there is not the makefile, so when I run make, I receive this error make: *** No targets specified and no makefile found. Stop. Here the output of ./configure

loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal-1.4... missing
checking for working autoconf... missing
checking for working automake-1.4... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for strerror in -lcposix... no
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for Cygwin environment... no
checking for mingw32 environment... no
checking host system type... x86_64-unknown-linux-gnu
checking build system type... x86_64-unknown-linux-gnu
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking for a sed that does not truncate output... /bin/sed
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for object suffix... o
checking for executable suffix... no
checking command to parse /usr/bin/nm -B output... ok
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 gdk-2.0... 

How can I solve?

  • Is there a particular reason why you font want to: sudo apt-get install gtkterm? – Tshilidzi Mudau Dec 19 '15 at 12:11
  • I would like try to install the program going through the ./configure method so I learn something new. – linofex Dec 19 '15 at 12:30
  • 1
    Add the full output of ./configure to your question. – A.B. Dec 19 '15 at 12:41
  • This is a dependency issue. You need to install al the dependencies needed before you can ./configure, see my edit below. – Tshilidzi Mudau Dec 19 '15 at 13:22
  • That isn't the full output of ./configure. – A.B. Dec 19 '15 at 13:32
3

You can easily install GTKTerm from the terminal using sudo apt-get install gtkterm.

EDIT

What you are looking at is a dependency problem(i.e. see lines like aclocal-1.4... missing). You need to install all dependencies which are required before for you can compile GTKTerm, to install this dependencies, use this:

sudo apt-get build-dep gtkterm

Once you have done this, you should be able to run ./configure without any problems.

-1

make takes a makefile as input. Makefile usually is named makefile or Makefile. The configue command should generate a makefile, so that make could be in turn executed. Check if a makefile has been generated under your working directory.

  • This is the problem, after ./configure there isn't the makefile. The are only two makefile in the folder (since before the ./configure): Makefile.am and Makefile.in – linofex Dec 19 '15 at 13:06
  • are you in root ? – orvi Dec 19 '15 at 13:11
  • Yes, I ran the commando with sudo – linofex Dec 19 '15 at 13:13
  • Did you install the all dependencies? GtkTerm has a few dependencies- Gtk+3.0 (version 3.12 or higher) vte (version 0.40 or higher) intltool (version 0.40.0 or higher) – orvi Dec 19 '15 at 13:24
  • 1
    Or you can look at my edit to see how to do that :). – Tshilidzi Mudau Dec 19 '15 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.