When booting via grub I get the following error:

error: unknown filesystem.
grub rescue> ls
(hd0) (hd0,msdos7) (hd0,msdos6) (hd0,msdos5) (hd0,msdos1) (fd0)
grub resuce> set

If I change the root and prefix to hd0,msdos6 I can boot successfully. Except grub encounters the same error when I reboot. How can I get grub to remember these settings?

Potentially useful information:

  • I am using RAID0 and grub is installed to /dev/mapper/isw_fbifcgeic_RaidVolume0
  • In Linux (Ubuntu 11.10) my grub.cfg points to root at (hd2,msdos6)
  • grub-mkdevicemap -m - lists the /dev/mapper entry at hd2

Any help would be much appreciated! It's super annoying needing to rescue grub every time I boot my system.


It turns out that my raid0 configuration was really a "fakeraid" configuration. It also turns out that there was a bug in grub-probe related to fakeraid. Once I ran sudo update grub-pc followed by grub-install /dev/mapper/isw_fbifcgeic_RaidVolume0 I could successfully boot my computer once more without manual intervention.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.