4

I'd greatly appreciate any help with the following. I have problems with video display, occurring in VLC, SMPlayer and in Skype. For VLC and SMPlayer I have found a workaround, for Skype not. The problem is that the video does not resize and it remains on top of other windows, even when I switch to other applications. The Skype image flickers.

Details about the problem and how to produce it:

  • Clean install of Ubuntu 15.10 AMD64 on an Asus
  • Install VLC and SMPlayer and Skype
  • Open any video in VLC
  • Resize the VLC window.

What happens now is that the video itself does not resize. It remains the same size but is centered in the VLC window. The remaining space in the VLC window is filled with blue. This blue flickers blue/black while I resize the window. Furthermore, the video frame is on top of other windows, even when I switch to another application. It also overlaps with the pull-down menu of VLC itself, meaning that I cannot read most of the options in the menus because the video is on top of them. Surprisingly, when I go to VLC Tools, Preferences, Video, and select at Output "OpenGL GLX video output (XCB)" then the problem disappears and everything is normal. Same thing for "X11 video output (XCB)". The problem re-appears however when I choose "VDPAU output" or "XVideo output (XCB)" or, for that matter, "Automatic".

So for VLC I have a workaround. But for Skype I do not. The Skype problem is similar:

  • Open Skype, make a call, activate the web cam.

The video of the person receiving the call is fine until I open my own webcam. The image flickers continuously (blue).

Background about my machine:

  • Asus UX305C.

Details from lspci:

floris@ava:~$ lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 08)
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:15.0 Signal processing controller: Intel Corporation Device 9d60 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Device 9d61 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d13 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d46 (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
01:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

Kernel:

floris@ava:~$ uname -r

Ubuntu:

4.2.0-19-genericfloris@ava:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:        15.10
Codename:       wily

Any help or thoughts appreciated!

  • Same problem here with xps13 9350 with skype and VLC (didn't try SMPlayer). This issue ( bugs.freedesktop.org/show_bug.cgi?id=92324 ) might be related. It seems it's the graphics drivers that doesn't handle outputing 2 HD videos at the same time. – Dolanor Jan 3 '16 at 22:52
  • I've illustrated the problem here. It's easier to see than to describe ;) youtube.com/watch?v=MBL2BAU8Vyk – Floris Jan 12 '16 at 14:57
  • I installed the kernel 4.6 for the mousepad issues but the graphics issues persisted. I had the same problem with the graphics and now it's just dead. Most times won't even boot up, and when it does it just totally freezes after few seconds-minutes. Luckily I could do a backup in one of those moments. Model: UX305CA (new-ish one). – Francisco Presencia Jun 1 '16 at 17:35
0

Kernels before 4.3 did not handle Skylake Intel well. Upgrading to a later kernel (eg 4.4.4 or 4.4.5) may help as they are supposed to handle Skylake graphics.

  • 1
    FWIW I still have this issue on 4.4.0-45. – BeeOnRope Nov 4 '16 at 16:10
0

What worked for me was using the nomodeset option in the grub bootloader. There are two methods to set nomodeset:

  1. Temporary:
    • While booting press and hold shift in order to see the grub menu
    • Choose the entry you want to change (in a normal installation the first entry) and press e to edit it
    • Look for quiet splash and add nomodeset before it
    • Finally press F10 to boot.

If this worked for you, you can use the permanent way for all bootups.

  1. Permanent:
    • edit /etc/default/grub (for example: sudo nano /etc/default/grub)
    • change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"
    • Finally update the grub config: sudo update-grub

The next time rebooting, you don't have to specify the boot option.

I run Ubuntu 16.04 LTS with 4.4 kernel on Lenovo i310 laptop.

The output for sudo lshw | grep -A9 VGA is the following:

description: VGA compatible controller
product: Sky Lake Integrated Graphics
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 07
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0

This answer is partially copied from last answer at When I start my camera in video call on Skype 4.1. incoming video is flashing blue?

  • You say this worked for you, but what issue did you have? I would be very surprised if nomodeset affected video playback issues. General graphic display problems, yes, but everything working fine except video? Did you really have a similar problem which you solved like this? – terdon Nov 22 '16 at 9:58
  • I had two problems. First VLC, my problem is exactly how described by Floris. I did not try to change preferences in VLC, though. Second Skype, it is the same as described by Floris. Adding 'nomodeset' solves both problems for me. – janclod Nov 22 '16 at 22:42
  • OK, fair enough. – terdon Nov 23 '16 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.