I am very new to Ubuntu and I've installed Ubuntu 14.04 in English and than added Hebrew to it (as a second language).

When I switch from English to Hebrew via Left-Alt+Shift (The combination I defined) I can use the language itself just fine but I can't switch between it and universal-characters\ Key-alternatives via Caps lock key (as I can with all versions of Windows).

In Hebrew keyboards we use Caps lock for alternative usage of some keys. For example:


Note: Both characters from each side of the equality mark are initiated by the same key in typical English-Hebrew keyboards - Depends on Caps lock.


I just installed Hebrew keyboard, tried to enter ף ץ ת and ;,. using a Keyboard Layout Chart and did not encounter a problem. To show the chart, in status bar click the language icon > Keyboard Layout Chart.

If you need to display character from right bottom corner of the button on this chart, use combination with the Alt button on the right side Alt Gr. For example Alt Gr + > will give you comma: ",".

This chart will also tell you what characters will be displayed after using Shift (upper left side).

enter image description here

To activate alternative keys, go to main Ubuntu Settings > Keyboard and in the Shortcuts tab under Typing set Alternative Character Key to Caps Lock.

enter image description here

| improve this answer | |
  • This problem seems to me to be only Physical-keyboard related... In all humbleness, the most general and efficient way of solving it will be a way to use Caps lock to activate the alternative keys for the Hebrew-on state... – user423047 Dec 18 '15 at 17:41
  • @benos Hi, so I edited my answer with instructions to set Alternative Character Key to Caps Lock. – Mike Dec 18 '15 at 18:31
  • MIke, I encounter something very wried: From the moment I went to System settings > Keyboard > Shortcuts > Typing and setted the ACK to Caps lock --- I could no longer use Caps lock with my keyboard... Even it's light on the keyboard itself didn't light in all the times I clicked on it... But as you can tell for now I've brought the ACK to "Disabled" again... Something here is wired indeed... – user423047 Dec 18 '15 at 18:40
  • @benos Looks like you found a bug, because I have same problem here, once you set the Alternative Character Keys to Caps Lock, Caps Lock is out of the game, stops responding even if Hebrew is uninstalled. – Mike Dec 18 '15 at 18:50
  • Oh WOW... Well, since I'm so new in the business, can you please advice me where is the best place for me to report this? Or would you like to have the honor yourself? – user423047 Dec 18 '15 at 18:54

Another trick, at least for the Hebrew points (this is the only thing I used CAPS LOCK in Windows for), is to use Alt Gr pressed together with some number. For example, Alt Gr+1 yields ֱ
In my opinion, it is easier than in the Windows layout (one key instead of two)

Also, Alt Gr+ ש = ₪ , unlike in the Windows layout

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy