0

I have a secondary hard disk (8 TB, ext4) that does not auto-mount on OS startup despite "auto-mount" being set to "on" within the "Mount Options" of the "Disks" utility application.

How do I enable the auto-mount option to have this effect?

I am running 14.04. The disk is housed within a trayless removable rack and is present prior to powering the system. There is no problem using the disk once I have mounted it manually.

===

Output of sudo blkid;cat /etc/fstab:

/dev/sda1: UUID="7c101c3e-7f80-4744-aa34-7a111a5c16a4" TYPE="ext4" 
/dev/sda5: UUID="022e4360-27be-4f6e-909a-e10a91ee8046" TYPE="swap" 
/dev/sdb1: LABEL="data" UUID="4270461f-dacc-4ea1-846b-b79b19870ae2" TYPE="ext4" 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=7c101c3e-7f80-4744-aa34-7a111a5c16a4 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=022e4360-27be-4f6e-909a-e10a91ee8046 none            swap    sw              0       0
  • Open terminal and run command: sudo blkid;cat /etc/fstab. Post output – Sergiy Kolodyazhnyy Dec 18 '15 at 1:43
  • Also, you might try following this tutorial.docs.system76.com/articles/extraDrive It is posted by System76, but is not specific to their machines. You might find some helpful information or some steps that you missed – elethan Dec 18 '15 at 2:05
  • @Serg: I've updated my question with the output. – Josh Dec 18 '15 at 9:33
1

The contents of your /etc/fstab file suggest that only two block devices get mounted - your Ubuntu partition, /dev/sda1 and your memory swap partition, /dev/sda5 , both of which are on the same disk /dev/sda

What you need to do to automount the secondary hard disk is to edit the /etc/fstab in accordance with output of blkid (the first 3 lines).

Run pkexec gedit /etc/fstab in terminal, to edit that file with super-user privilege. Add the following line:

UUID=4270461f-dacc-4ea1-846b-b79b19870ae2 /media/SECONDARY ext4 noatime,nodiratime,user=1000,rw 0 0

Save and exit the gedit text editor

Note, you should create /media/SECONDARY folder before reboot with sudo mkdir /media/SECONDARY. SECONDARY doesn't have to be the name, you can change it to whatever you want, but keep in mind to change it in /etc/fstab as well.

Note also the option user=1000 . Assuming you are the only user on your system, 1000 is default for first user ever created, hence that option. Verify your user id with id -u command. Change accrodingly

As for your original issue, I am not familiar with Ubuntu's disks utility, so I don't know possible reason for it not working. I would assume it performs the same task as editing /etc/fstab manually.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.