My internet connection is slow and unreliable. Sometimes pages will eventually load, but other times I will get a server not found message. Refreshing the page often fixes that. Sometimes it takes several tries. I'm assuming that it's a driver issue because I haven't done anything with this adapter other than put it into the USB slot, but I haven't been able to update my drivers successfully.

I am currently using Ubuntu 15.10 with an Edimax EW-7811Un N150 USB adaptor.

I borrowed a different USB adapter (I do not have the model for it, but I was told that it came out of a kit for a Raspberry Pi) and the internet worked perfectly with it. For scale, I was able to get 600-700 kb/s on Steam downloads with the borrowed adapter and I get from 0-100 kb/s with the Edimax.

I already tried the procedure here after bouncing between links in a few similar questions: NETIS WF2120 Wifi Adapter Drops Signal Within Seconds

When I tried that, I lost my ability to connect to the network completely. I couldn't figure out how to fix it without being able to look things up online, so I reinstalled Ubuntu and came here to ask for help.

I don't really know what I'm doing, so I'm probably going to need specific commands to input into the terminal. Other people with this problem seemed to be posting the output from lsmod, so here is mine:

EDIT: Formatting came out very poorly on the lsmod output. Replaced with pastebin link: http://pastebin.com/zrDCL6Kp

Thank you!

  • Don't know if this works on 15.10, but it used to work on older releases. Edimax EW-7811Un and other rtl8192cu adapters' support has been reported as garbage quite a few years ago. I doubt it will ever get fixed. – mikewhatever Dec 17 '15 at 0:32
  • That seems to be mostly working now. The popup that said I was connected to the network couldn't figure out the network's name, but it runs reasonably fast so I'm satisfied. – Tmatthe8 Dec 17 '15 at 1:25

You might want to check if power management is enabled on the WiFi dongle as this can lead to unreliable connections. You can check using the iwconfig command (e.g. for wlan0):

iwconfig wlan0 

To disable power management use:

iwconfig wlan0 power off

There are also other parameters that may be adjusted to improve reliability (e.g. retry, rts, etc) using iwconfig and/or the iw command. The iw command relies upon the nl80211 module which isn't always available - e.g the Edimax card on Raspberry Pi currently doesn't support nl80211 but iwconfig still works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.