2

So I have a 64 GB USB stick which is formatted as NTFS since I use it to transfer stuff between Ubuntu and Windows (as well as files larger than 4 GB, so no FAT 32). At the moment I need to copy a large amount of files (3000+ images, each one up to 1 MB in size) from Ubuntu to Windows. Problem is, when I click eject on the drive in Ubuntu nothing happens. I've waited like 10 minutes, still nothing. If I press eject again or try to access the drive in the files browser, it tells me that 'another operation is already pending'. So the first time I tried, I just pulled it out after a couple of minutes (assuming nothing would happen, I've never had to eject something under Windows). Bad idea, most of the image files were damaged and could not be opened anymore using either OS. So I tried again, but it's been like 15 minutes and still nothing happened (the stick still shows up in the files menu) ...

What might be causing this? Any idea how I can eject the drive properly (and safely)? Or is Ubuntu just not made for dealing with NTFS-drives / USB-sticks that large?

I'm running Ubuntu 15.10. Let me know if you need any more info. Thanks!

2

I think the images are being copied in the background. Sometimes, it shows copying process is completed in the progress bar, but it's not.

Also, the amount of data seems to be large and it will take time. I suggest you to try:

  • Copying small amount of data (like 50 or 100 images) first.
  • Using a different port like USB 2.0 (if already on 3.0).

Try the disk utility application. There is an option for powering off the device on upper right side.

Edit: Install indicator-multiload to have real-time view of what's going on behind the scene.

| improve this answer | |
  • Why would it do that? °A° Thanks, I will try it! I'll report back as soon as I get to it ... is there any way to check when the copying process is actually done? – MoritzLost Dec 16 '15 at 23:07
  • I don't know the reason behind the behavior. But I faced this. And to check the actual progress, you may use the applet that tells the current disk, network, CPU usage. And from the disk usage (graph) you can have an idea of what's going on! I don't remember the name of the applet. Will tell you soon! – Mandeep Singh Dec 16 '15 at 23:19
  • 1
    Install an indicator: indicator-multiload – Mandeep Singh Dec 17 '15 at 9:40
  • Also try this: askubuntu.com/a/410140/356502 – Mandeep Singh Dec 20 '15 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.