Short question: I have reason to install a specific version of nfs-common on a new machine. I want to install 1:1.2.8-6ubuntu1.1. I believe that I need to sudo apt-get install nfs-common, but I'm not sure how to specify the version. I've tried the obvious of:

$ sudo apt-get install nfs-common=1:1.2.8-6ubuntu1.1
E: Version '1:1.2.8-6ubuntu1.1' for 'nfs-common' was not found

Long question: I'm trying to install nfs-common over a docker image. At first attempt, I just did apt-get install nfs-common. This failed, presumably because:

The problem is that nfs-common has been updated in the backports repo, but portmap has not, and the new nfs-common and old portmap are not compatible. So to install it either disable backports, or use force version to install the previous version of nfs-common.

— Source: Crunchbang.org: [SOLVED] nfs install failure.

OK, I'm happy to force a previous version of nfs-common. This would match another machine that was setup months ago, presumably before the latest version was available. Going to that machine and running apt-cache policy nfs-common, I see it has installed 1:1.2.8-6ubuntu1.1. Looking at man pages for it and:

  1. How to install specific version of some package?
  2. How to install specific Ubuntu packages, with exact version?

I see that I need to do something like apt-get install nfs-common=1:1.2.8-6ubuntu1.1. However, I cannot figure out the exact syntax. When I tried the above, I received E: Version '1:1.2.8-6ubuntu1.1' for 'nfs-common' was not found. I received the same error if I used 1:1.2.8-6ubuntu1.2, which is the default version that's installed.

Obviously I'm not understanding something about the version specified, and I can't seem to find any examples on the web for installing a specific version of nfs-common (or some component that I can map to installing an old nfs-common).

Any help would be appreciated.

Additional note: I tried following the advice at Debian User Forums: nfs-common and dpkg errors. I had to add an apt-get update. However, doing the apt-get install nfs-common ended up failing with

dpkg: error processing package nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 10
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • On the machine you reference with the correct version, it looks as though apt-cache policy should also output the url associated with the package. Can you verify whether this url is accessible (in the apt sources list??) on the target machine?
    – tniles
    Dec 16, 2015 at 22:41
  • Also, if you have the package itself downloaded on the reference machine, maybe you can just scp it over to the target machine and install it manually?
    – tniles
    Dec 16, 2015 at 22:42
  • Although I might be able to fight uphill to get this working, it seems like I should be able to do apt-get install nfs-common=<default version>. It I could get that to work, I could try seeing if I could change the version from 1.2 to 1.1. But, I can't get that to work either. That said, regarding your specific suggestion, I see http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages. Unfortunately, I'm not sure what to do with that information. I'm used to the basic usages of apt-get only. Dec 16, 2015 at 22:57
  • Does this answer your question? What is correct way to fix name resolution from Docker container?
    – Henke
    Nov 3, 2020 at 14:30

1 Answer 1


Here you can download the package in .deb . Another solution is to install through apt-get the closest lower version, which is available, ie. 1:1.2.8-6ubuntu1.1 if that would do.


It installs easily too, at least from 1:1.2.8-6ubuntu1.1 up in case it doesn't.

enter image description here


But you need to check yourself if it works alright. You will anyhow :-).

  • sudo dpkg -i /tmp/nfs-common_1.2.8-6ubuntu1.1_amd64.deb returned: dpkg: dependency problems prevent configuration of nfs-common: nfs-common depends on libgssglue1; however: Package libgssglue1 is not installed. nfs-common depends on libnfsidmap2; however: Package libnfsidmap2 is not installed. nfs-common depends on libtirpc1; however: Package libtirpc1 is not installed. nfs-common depends on rpcbind (>= 0.2.0-6ubuntu1); however: Package rpcbind is not installed. Trying to install libgssglue1 gave me further errors. Dec 17, 2015 at 0:01
  • this may seem stupid, but can you just double-click the file in GUI?
    – user436099
    Dec 17, 2015 at 0:07
  • or: sudo apt-get install -f
    – user436099
    Dec 17, 2015 at 0:10
  • if still in trouble, go over this one askubuntu.com/questions/140246/…
    – user436099
    Dec 17, 2015 at 0:18
  • sorry, i might have flown off a bit. take a look at this one if you got stuck in my second comment superuser.com/questions/196864/…
    – user436099
    Dec 17, 2015 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.