0

I've recently upgraded from Ubuntu 14.04 to Ubuntu 15.04 (Vivid Vervet) and I'm busy installing some programs and games I had running on Ubuntu 14.04.

I was installing Grand Fantasia, everything went well, except for the fact that my characters were invisible. I had experienced this earlier too, on Ubuntu 14.04, but at that time, I fixed it by adding three DWORD-values in the registry: MaxShaderModelGS, MaxShaderModelPS and MaxShaderModelVS (all of them had value 0).

However, this time, it didn't fix the problem. At first, I tried adding some other strings to the registry, but nothing seemed to work. I also tried googling for a bit, but I couldn't find anything that worked for me.

Does anybody know how to fix this problem?

I use Wine 1.7.46 and PlayOnLinux 4.2.9 on Ubuntu 15.04 (Vivid Vervet)

Thanks in advance,

Regards, Rutgervdp

2
  • 1) Install new Wine. 2) Try adding the native DX/other DLLs into Wine. 3) Try installing old Wine. 4) Try messing with those settings. - If those don't work, either go back to 14.04, or you can just use Xen and virtualize a GPU (you need two GPUs for this).
    – Apache
    Dec 16, 2015 at 16:19
  • Hello Shiki, thanks for your quick response! I tried messing with the settings when I came across the "registry edit" button in PlayOnLinux. I clicked it and I discovered that I had added the strings in the registry of the system-wine version instead of the wine1.7.46. I added it in the registry of my GrandFantasia Virtual Drive in POL and it worked!
    – RutgervdP
    Dec 16, 2015 at 16:34

1 Answer 1

0

Your problem seems to be very specific to this game. Always consult Wine's application database in https://appdb.winehq.org/ before installing any new programs through Wine. If there are problems, AppDB will probably have a workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.