0

I am trying to install mod_mono on Ubuntu Ubuntu 14.04.3 LTS. I have tried following command and got error:

sudo apt-get install libapache2-mod-mono mono-apache-server

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-mono : Depends: mono-apache-server (< 3.8.1) but 4.2-2~xamarin1 is to be installed or
                                mono-apache-server4 (< 3.8.1) but 4.2-2~xamarin1 is to be installed or
                                mono-apache-server2 (< 3.8.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have installed latest mono version.

 sudo apt-get install mono-complete

Please suggest me what should I do?

Thank you

0

Install mono-apache-server4 instead of mono-apache-server with libapache2-mod-mono

So, try:

apt-get install libapache2-mod-mono mono-apache-server4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.