2

This question already has an answer here:

I have ubuntu 14.04.3 installed on my new machine equipped with an nvidia geforce 970.

Not to mention the pains I had in installing nvidia.352, last night I made a simple update and shut down. However, this morning I had the black screen login page instead of the graphical. There was a problem with nvidia I figured. So I tried to downgrade to an older version. It didn't help. Last thing I did was to purge nvidia. After reboot, however, this time I don't even get the black login page. Instead, the screen shuts down and there is nothing I can do.

I tried with recovery mode through GRUB. However, no matter which one of the options I choose, I always get the same problem. The screen shuts down and I have to reboot manually. So no terminal, no login, just the system boot settings.

After a fair amount of search, I found out that there is an issue with a concept called nomodeset which has to be set through grub. As this link suggests, I searched for the line starting with linux and ending with quiet splash to add nomodeset there. However, what I have is this:

linux   /boot/vmlinuz-3.19.0-33-generic root=UUID=f40f49f8-a44b-4709-b79b-0873ca3c3b72 ro /

So there is no quiet splash to add nomodeset to. However, if I anyway try to add either nomodeset or nomodeset quiet splash in the end of the line and then reboot, it halts and I need to reboot manually.

So my question is: Is there anyway that I can have at least an access to a terminal by modifying GRUB?

At this moment I need to have a terminal to try to recover my files if possible and then maybe install nvidi again.

marked as duplicate by David Foerster, hg8, Ravan, Charles Green, Eric Carvalho Dec 18 '15 at 23:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Just add the nomodeset at end of line. Not sure / at end of line is correct either. Did you try recovery mode? It should have nomodeset already in linux line. – oldfred Dec 16 '15 at 16:00
  • I trieddifferent things. I added either nomodeset or quiet splash nomodeset or nomodeset quiet splash or nouveau.modeset=0 at the end of the line and then rebooted. Still the same error! – Sohrab Dec 16 '15 at 17:45
  • Also the recovery mode brings the same result: screen shuts down after reboot! – Sohrab Dec 16 '15 at 17:47
0

Remove the currently installed drivers and install the latest stable drivers supporting GTX 970.

Step 1 - Uninstall the old NVIDIA drivers - boot the PC - when the GRUB menu appears :

Highlight the Ubuntu menu entry and press the E key.
Add nouveau.modeset=0 to the end of the linux line.
Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1.
Enter your user name and password - then execute :

sudo apt-get purge nvidia*  
sudo reboot  

Step 2 - Install the new NVIDIA drivers - boot the PC - when the GRUB menu appears :

Highlight the Ubuntu menu entry and press the E key.
Add nouveau.modeset=0 to the end of the linux line.
Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1.
Enter your user name and password - then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358
sudo reboot
  • I added nouveau.modeset=0 to the end of the linux line and pressed F10. However, after the reboot, the same story. I see the purple screen (without any logo) for several seconds. Then it would automatically reboot again and finally the black screen again. – Sohrab Dec 16 '15 at 17:42
  • @Sohrab : Please repeat the same procedure but this time add nomodeset instead of nouveau.modeset=0 to the end of the linux line. – cl-netbox Dec 16 '15 at 18:31
  • I'm afraid it didn't work. I also tried with nvidia.modeset=0. That didn't help either. – Sohrab Dec 16 '15 at 19:30
  • @Sohrab : Please check whether there are graphics or monitor settings in BIOS that have to be switched. – cl-netbox Dec 16 '15 at 19:36
0

I could not yet make the system working by adding the suggested terms to the GRUB. However, when I run the same trick (adding nomodeset to the end of linux line in GRUB) on ubuntu USB boot, I can login as ubuntu (otherwise I have the same problem: screen shuts down).

Is there any way that I can modify the booting procedure (GRUB, or installation of nvidia) for the main user on the failed ubuntu through this environment? It seems to me that this is the only way I can get some access to a terminal.

Being a complete beginner, I know I should first login as root. But then I have no idea how I could modify anything or even make a backup from this trial ubuntu from USB..

Not the answer you're looking for? Browse other questions tagged or ask your own question.