0

i can't install avahi

error is:

checking for AVAHI... yes
checking avahi-client/client.h usability... yes
checking avahi-client/client.h presence... yes
checking for avahi-client/client.h... yes
checking avahi-glib/glib-malloc.h usability... no
checking avahi-glib/glib-malloc.h presence... no
checking for avahi-glib/glib-malloc.h... no
checking for avahi_client_new in -lavahi-client... yes
configure: error: 
avahi development headers not found.
Use --disable-avahi if you do not need avahi (Bonjour) support.
0

You need additionally libavahi development packages. Without knowing what you try to compile I can only give you a list of available packages. Check this link.

But I believe, you need libavahi-glib-dev:

sudo apt-get install libavahi-glib-dev

The missing header file avahi-glib/glib-malloc.h is in this package.

  • this my question too.i don't know – Morteza Olyaei Dec 16 '15 at 7:31
  • As I said: sudo apt-get install libavahi-glib-dev – A.B. Dec 16 '15 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.