4

I use Ubuntu 15.10. I updated the available updates today. Almost after an hour the software updater stays idle "Configuring grub-pc". I can browser without problem. Is it ok to kill job or restart. Can you suggest what to do?

software updater stays idle

1
  • I ran into this with a pre-built VM of 15.04 from virtualboxes.com
    – TecBrat
    Sep 15 '16 at 17:49
3

I can't confirm that it is safe to kill the job, but if it stays frozen, then you won't have much of a choice.

With some basic googling this seems to be a decently common issue, with a LP issue filed back on the 21st of May, 2015 against Software Updater for this exact issue.

It hasn't seen much activity, so it seems like it may be a fairly niche/one-off bug, but you can try killing the update manager and running sudo apt-get install libgtk2-perl and then running sudo apt-get update && sudo apt-get upgrade.

It shouldn't break things, but since I've never actually had this happen, nor would I be able to test it, I can't be entirely sure. However, we'll be more than happy to help if things do break.

2
  • I just restart the system as such. It booted without anyproblem. Perhaps this may be a bug. Thanks for the information.
    – catuf
    Dec 16 '15 at 9:36
  • @Suresh No problem, glad I could help. If you are able update again without it freezing, could you click the check-mark next to my answer? It let's other people know that my answer solved your problem and is the normal method of saying thank you here on Stack Exchange Dec 16 '15 at 13:25
0

I ran into this problem consistently and I think I've found the cause and solution: I killed Software Updater process and followed the advice of previous poster "RPi Awesomeness" and typed sudo apt-get install libgtk2-perl at CLI. First Ubuntu gave an error and told me I had to type another command, which I did, and received an error about things being locked (presumably because of the killed process). So I rebooted, and tried sudo apt-get install libgtk2-perl again at CLI. This time a text screen came up about grub, which to be honest I had been messing around with previously because I need the bootloader to be on an external drive, while Ubuntu is installed on the internal drive. I guess this text window had been there all along but while using the Software Updater it wasn't visible. So, the solution seems to be to do it from the command line interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.