0

I'm trying to set up a dual boot on my yoga 2 pro running windows 10 (shipped with win8), trying to install ubuntu 14.04.3

I've disabled secure boot and fast boot in bios setup. When installing, I created the following partitions manually:

/ = all free space minus 8 gb, swap = 8 gb

and pointed bootloader to install to default selection, which was /dev/sda (which says my 256GB SSD). /dev/sdb description was my installation media.

Then during install it fails to install grub2. So I tried again but this time selected the windows boot loader efi partition which was /dev/sda2. Same error with grub2.

I did try searching and tried a solution that worked for someone elses yoga 2 pro, to install grub-efi-amd64 and run grub-install /dev/sda which produced an error.

Then tried the installer again but this time subtracted 300mb from my root partition and used it to create /boot and pointed the bootloader to install there. The install worked without error, but when I shut down and power on it boots up windows. And when looking in boot up menu there is no option to boot up ubuntu. I then booted back into ubuntu live and tried boot-repair and did recommended repair, and it fails.

When creating the boot partition, the first time I selected ext2 formatting, which made the installer finish successfully, the second time I tried efi and it causes the installer to fail.

Can anyone help? If anymore details needed please let me know thanks.

  • Please post the URL that Boot Repair gave you. Without it we can only guess. My guess is that you've enabled the Compatibility Support Module (CSM; aka legacy boot support), which is wreaking havoc. If I'm right, you should disable the CSM and try again. See this page of mine for details. – Rod Smith Dec 16 '15 at 14:37
0

Solved

Not quite sure why this solution works, still a little confused what the issue was but I disabled fast start in windows, then went back into ubuntu live and ran the installer and selected 'reinstall ubuntu'. The installer worked, and now the system shows grub on startup, giving the option to boot into ubuntu or windows. To sum up, only changes I made in bios were disabling secure boot, and fast boot.

Also not sure why every ubuntu related discussion for the yoga 2 pro says you must add parameter 'acpi_backlight=vendor' when booting, I did not need this. It only locked the brightness at max and broke the brightness keys which work out of the box.

Side note, ubuntu is amazing on high end specs. Only issue with the yoga 2 pro on linux is the yellow color issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.