This isn't a question about Ubuntu being laggy in general - not at all, in fact, it's very slick and fast for me. Clicking the "Workspace Switcher" in the dock performs the animation immediately and very smoothly. Switching between workspaces with the arrow keys - again, flawlessly.

My computer has a resolution of 2560x1440 on a 27" display (no, not an Apple product - though my monitor has the same panel that Apple use in their cinema displays). It's powered by an Nvidia GeForce GTX 470 - easily enough to handle it - and an Intel i3. Hardware is not the issue.

I am running Ubuntu 11.10 (upgraded from 11.04). I had the same issue in 11.04.

I'm running the "NVIDIA accelerated graphics driver (post-release updates) (version current-updates)" from the additional drivers dialogue. Two drivers have been suggested to me via that dialogue and I've tried both - same effect with each. The driver is "activated and currently in use".

Any other information required, let me know and I'll post it. I'm a programmer who works with Linux daily (both as a job and as an interest) so technical instructions are fine.

I've noticed that Compiz uses a lot of CPU when moving windows around and it's memory usage is relatively high (though possibly expected for Compiz):

1671 user 20 0 478m 286m 33m S 1 7.3 12:44.05 compiz

And one more thing - occasionally moving windows around is fast. But it only happens when all applications are closed, and even then it sometimes doesn't. Something must be interfering, but what? I'll try and find out but in the meantime, any suggestions are much appreciated :-)

  • I've been working in launchpad to try and figure out this very issue. I've finally understood enough recently to report a fresh bug report knowing that it isn't a duplicate of the myriad of similar-but-not-quite-right reports. I advise you head over: bugs.launchpad.net/ubuntu/+source/compiz/+bug/888039
    – user6658
    Nov 17, 2011 at 2:49

11 Answers 11


I don't know why this happens, but the following worked for me:


I've changed my mousepolling to "10" which has solved this problem.

Instructions for anyone who would like to replicate my solution:

sudo gedit /etc/modules

Append the following:

-r usbhid
usbhid mousepoll=10

Save the file and reboot. To verify that the setting is in effect, run the following command:

cat /sys/module/usbhid/parameters/mousepoll

If the result is "10", you have succeeded. You should also now have smooth window movement.



I have the same issue and I've been troubleshooting it for some time time. Turning off V-sync in compiz and nvidia-settings does help a bit, but it doesn't solve it entirely nor do I think it's the cause of the problem. And when I check PowerMizer, everything looks ok. It is set to Maximum Performance (Performance Level 0), so I doubt this is the problem.

You can try to manually add the following line to the Device section of /etc/X11/xorg.conf:

Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"

Just make sure that the indentation is the same as the other lines in there.

When I recorded this behavior I noticed that the mouse in the recording moves around normally while on screen it was freezing just like the rest of the desktop. Not sure if this helps, but thought it might be worth noting.

I have come to the conclusion that this gets worse over time. It is all fine right after boot (or restart of Compiz or X). But after a while it gets more and more sluggish until moving windows around will more or less freeze your whole desktop (like in screen cap) until you stop moving it. Memorly leak perhaps?


I have the same problem on 3 computers all running Ubuntu. I found that the only solution was to go back to Ubuntu 11.04 (and miss out on all the 11.10 goodies - like the new and improved Software Centre).

I believe this is the bug report for this problem:


I hope it is fixed soon so that Canonical will reach its 200 million user target :).

  • 1
    This seems to suggest that all graphics performance is hit but for me this isn't the case. It's just the moving of the windows that is laggy for me.
    – user18192
    Oct 27, 2011 at 16:48
  • Looks like my what I am suffering from
    – n3rd
    Dec 8, 2011 at 7:13

The solution that worked for me was CCSM >> Composite >> Disable the automatic refresh rate, and manually set it to anywhere below 25.


There can be an issue with cards that have powermizer & are set to 'adaptive', though not sure that's the case with you, ie. that you have powermizer - ck. nvidia-settings.

In the above case whenever the gpu clock is at it's lowest setting there can be a small lag when an action requires a higher clock speed. Moving windows is one such example, some scrolling scenarios also show this.

If you have powermizer, - to test - set the preferred to Max performance & see. This setting only lasts till unset in nvidia-settings or a restart.

If this is the case this can be adjusted in xorg.conf, I use a section that keeps the gpu on max when on ac, on adaptive when on battery.

This behavior is only seen here with compiz-0.9.X, worse in 11.10 than 11.04 where it was minimal


Try this, install CompizConfig Settings Manager go to the OpenGL settings and disable Sync to vBlank.

  • Didn't seem to do anything, I'm afraid.
    – Muu
    Oct 23, 2011 at 15:54

Aha! If you install the compiz settings manager and go to "Move Window" and turn the opacity right down to 1, it is no longer laggy for me. Now hey, that's not a perfect fix, in fact it's damn annoying but it's better than using Unity2D (which is buggy I find).

  • Identity disorder or just coincidence?
    – Beniamin
    Oct 28, 2011 at 7:55
  • How do you mean?
    – user18192
    Oct 28, 2011 at 9:38
  • I'm just kidding. You have exactly the same login as questioner (and I think that You is Him) but you have different reputation score.
    – Beniamin
    Oct 28, 2011 at 12:08
  • Oh, hehe, sorry I didn't realise what you meant. I'm the same guy, I just didn't sign in when I asked the question, instead asking anonymously. No idea why I'd ever do that, but I did :-P It's annoying as I can't accept an answer now :S
    – user18192
    Oct 28, 2011 at 12:54

I'm also having this issue. I'm running dual monitors on an nvidia 9600gt. I have so far noticed no other issue other than window moving. When I first boot up or restart or restart compiz the problem goes away. I can then launch two terminals. One I start up top in, the other I just start moving in a circle. Within about a minute of moving the window the movement starts to slow, then it starts to crawl. Soon enough I can move the mouse and not have the window follow at all. Looking over in the top window I see that Xorg is using about 60% cpu and compiz is using another 30% (core i7 860). Once I get the windows to start moving slowly, they will continue to move slowly no matter how much time I give the machine to recover.

I noticed that turning off window decorations in ccsm fixes the lag, but obviously makes for other usability problems.

I have also tried a whole host of settings Turning DynamicTwinView false Turning off Sync to blank in the ccsm Opengl Plugin Turning off "detect Refresh Rate" and setting refresh rate to 120hz *(which is twice my actual refresh rate) in CCSM Composite Plugin None of the above have fixed my issue.


Disabling this option made my window movements a lot smoother. CCSM>Utility>Workarounds.

I guess it has something to do with metacity

  • 2
    I have also enabled CCSM> General > Copy to texture. It helps with smoothness ( no idea why ) Dec 22, 2011 at 17:21


It's most probably a problem of the currently awfully buggy Compiz and some Unity bugs combined. There's plenty of the reports on launchpad. Check out my launchpad profile, go through the bug reports tracked here and try to determine which description fits your case most closely https://bugs.launchpad.net/~bucic/ For me it was https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/763005

I followed instructions there re disabling sync to vblank and adding the testing PPAs. Since then my desktop runs like it should.
The PPAs are ppa:vanvugt/compiz and ppa:vanvugt/unity
The instructions on how to add the PPAs are provided on their respective launchpad pages.
Make sure to do complete system backup before proceeding if you don't know how to revert the changes from testing PPAs. Also do a complete system backup each time before you apply updates. They are testing PPAs. They may "brake" something for you after giving you the solution you wanted and enjoyed for weeks.


You might want to take a look at this thread: http://ubuntuforums.org/showthread.php?t=1727008

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.