13

Is the Dell XPS 13 (9350) laptop compatible with the Ubuntu OS?

I'm new to Linux and Ubuntu but I'm minded to be a convert to open source software after disinterest in continuing to use Windows. I've been reading a lot of stories about problems with Linux failing to recognize the hard drive and the Wi-Fi has problems.

The laptop will come pre-installed with Windows 10 but I'm looking to erase that and install Ubuntu as my sole operating system. I'll try the Ubuntu demo first, but I'd like check on here as well.

closed as primarily opinion-based by dobey, Braiam, Pilot6, qbi, Eric Carvalho Feb 9 '16 at 12:52

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise. If this question can be reworded to fit the rules in the help center, please edit the question.

  • This will probably help: digitaltopo.net/o/?p=243 It looks like you need to change the wifi card and change the settings on your SSD, which will break windows... – Limecat Dec 15 '15 at 14:37
  • There are some issues with the current stable linux kernel (4.2) so you'll have to install and install a precompiled one. More info and discussions: sul.ccfink.de/?p=11 (complete install guide) wiki.archlinux.org/index.php/Dell_XPS_13_(2016) (additional info about bluetooth etc) There is also a link to the dell forums (I can't post because i don't have enough reputation) – user2295555 Dec 15 '15 at 21:04
  • 1
    If you want an XPS13, you should probably wait for the "Developer Edition" which will come with Ubuntu pre-installed, and supported by Dell. – dobey Feb 5 '16 at 15:32
  • too late, got one and wiped it :-D – Tim Abell Feb 11 '16 at 23:09
  • Please see my post. I ran into problem when using it and finally find a temporary way to bypass this. – Dean Chen Mar 29 '16 at 10:47
6

Currently there are still some compatibility issues with the default Ubuntu installation.
Here is what you have to do to get a properly working Ubuntu system installation ...


Preparation

First of all - you won’t be able to connect to the internet out of the box from Ubuntu 15.10
because the WiFi card currently is not supported - for the installation you will need either :

  • An USB Wifi or Ethernet adapter dongle
  • an USB key containing the following kernel compiled by Cephyr (this kernel contains an additional patch for using this WiFi card).

Ubuntu will not detect your disk at once because the SATA-controller is set to RAID On.
Boot into BIOS (Press F12 at startup) and set the SATA-controller to Off or to AHCI.

Note : If you want to keep a dual boot with Windows, you have to follow this procedure.


Installation

Create a bootable USB/DVD Ubuntu 15.10 installation media.
Boot from it by selecting it in the BIOS menu. Install Ubuntu as usual.

Fixing issues

WiFi

When the installation is done, open a terminal (Ctrl+Alt+T) and install the patched kernel :

#Only if you have a USB WiFi/Ethernet adapter
wget http://secretundergroundla.ir/?ddownload=15

tar jxf xps13_9350_kernel.tar.bz2
sudo chown root:root brcmfmac4350-pcie.bin BCM-0a5c-6412.hcd
sudo mv -t /lib/firmware/brcm/ BCM-0a5c-6412.hcd brcmfmac4350-pcie.bin
sudo dpkg -i linux-headers-4.3.0-wifitest-custom_4.3.0-wifitest-custom-10.00.Custom_amd64.deb linux-image-4.3.0-wifitest-custom_4.3.0-wifitest-custom-10.00.Custom_amd64.deb

Reboot and WiFi should work properly now.

Update the system :

sudo apt-get update
sudo apt-get upgrade

Bluetooth

To make Bluetooth work properly you have to install the Broadcom firmware.

wget http://downloads.dell.com/FOLDER03272920M/1/9350_Network_Driver_XMJK7_WN32_12.0.1.720_A00.EXE
unzip 9350_Network_Driver_XMJK7_WN32_12.0.1.720_A00.EXE
cp Win64/BCM4350C5_003.006.007.0095.1703.hex ./
hex2hcd BCM4350C5_003.006.007.0095.1703.hex
mv BCM4350C5_003.006.007.0095.1703.hcd /lib/firmware/brcm/BCM-0a5c-6412.hcd

Reload the module and Bluetooth should work.

sudo modprobe -r btusb   
sudo modprobe btusb

The Dell XPS 13 9350 is a good, but still quite new machine ... so please just give it some time,
everything will be fixed by Canonical and the community in the default Ubuntu installation ;-).


Sources :

Arch Linux Wiki,
XPS 13 (9350) WiFi with Ubuntu 15.10,
Install Ubuntu 15.10 on the Dell XPS 13 9343 (2015) : A complete guide.

  • Thanks. Is this the same for the LTS version Ubuntu 14.04? – 9Cleggy2 Dec 16 '15 at 18:45
  • 1
    This answer is slightly out-of-date now that 4.4 is generally available. You do not need to use the patched 4.3 kernel above. Instead follow the same instructions but install the 4.4 kernel. You may also need to disable ipv6 if you are seeing issues with wifi dropping. – jarv Feb 10 '16 at 11:54
  • 1
    Thanks a lot @hg8 for this answer. I have a XPS 13 9350 with ubuntu 15.10, with a custom 4.3 kernel installed for the wifi driver and the firmware gotten from the linux-firmware repo. But my bluetooth was pretty bad, but with the download from dell and your commands, it works perfect now. (before, it had a range of approximatively 30cm when using audio via bluetooth…) – Dolanor Feb 22 '16 at 21:47
  • Had problems with NVMe disks, but switching from Raid to AHCI worked for me (Ubuntu 16.04.1) thanks. – knocte Oct 3 '16 at 4:35
3

The following works:

First we upgrade the linux kernel to 4.4.

Download http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-rc7-wily/linux-image-4.4.0-040400rc7-generic_4.4.0-040400rc7.201512272230_amd64.deb and then:

$ sudo dpkg -i linux-image-4.4.0-040400rc7-generic_4.4.0-040400rc7.201512272230_amd64.deb

$ sudo apt-get update
$ sudo apt-get upgrade

Next install some updated firmware tools:

$ sudo apt-get install firmware-b43-installer

And then download and install the following firmware: http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.154_all.deb and

$ sudo dpkg -i linux-firmware_1.154_all.deb

Restart your machine, and you should have wifi!

0

I cannot comment sorry for making an answer. For Ubuntu 14.04 with Dell xps 13 9350 I installed kernel 4.4-rc6 which made wifi, bluetooth, suspend and audio work.

I made instructions based on all the instructions I found on the internet here: https://github.com/awesomebytes/ubuntu14_dell_xps13_9350

  • 1
    Hello awesomebytes, welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. ;-) – hg8 Dec 23 '15 at 16:23
0

Kernel 4.4 has been released and should fix most of the issues now. (I have it installed and not experienced any issues so far.

If your XPS 13 (like mine) is equipped with a NVMe SSD you'll have to compile a custom kernel where you enable the nvme module. Otherwise the kernel won't be able to find the SSD.

To do so, do the following: First get the necessary packages

$ sudo apt-get install git fakeroot build-essential ncurses-dev xz-utils
$ sudo apt-get install kernel-package
$ sudo apt-get install libssl-dev

Get kernel 4.4.

$ wget https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.4.tar.xz

Unpack it

$ tar xvf linux-4.4.tar.xz
$ cd linux-4.4/

Copy your current config file

$ cp /boot/config-$(uname -r) .config

Now edit the .config file with your favorite editor to enable the NVMe module.

nano .config

Search for CONFIG_BLK_DEV_NVME and set it to y (from m)

CONFIG_BLK_DEV_NVME=y

Now it's time to compile your custom kernel. (the last command can easily take up to 1.5 hours)

make-kpkg clean
fakeroot make-kpkg --initrd --revision=1.0.NAS kernel_image kernel_headers

And install! (ignore the warnings coming from the first one)

$ cd ..
$ sudo dpkg -i linux-headers-4.4.0_1.0.NAS_amd64.deb
$ sudo dpkg -i linux-image-4.4.0_1.0.NAS_amd64.deb

Now just reboot and it should start in kernel 4.4.

Additionally after a few reboots I ran into problem where my screen would remain black. Seems like thereś an issue with skylake and graphical drivers.

For me it was fixed by making a change to the grub file.

sudo nano /etc/default/grub

Then change the line saying GRUB_CMDLINE_LINUX_DEFAULT to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.preliminary_hw_support=1"

Save and apply the changes using:

sudo update-grub

Source for making custom kernel: http://www.cyberciti.biz/faq/debian-ubuntu-building-installing-a-custom-linux-kernel/

EDIT: Turns out after a few reboots my black screen is after boot is back.. so this is more of a work in progress.

0

As of this week, the newly released 4.4 mainline kernel is compatible with xps 9350 a few small simple additional configurations.

  1. create a new directory to hold all the bits we'll download

    mkdir v4.4-wily
    cd v4.4-wily
    
  2. download the latest kernel from ubuntu mainline (I used only the generic)

    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb
    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb
    
  3. Install that

    sudo dpkg -i *.deb
    
  4. get the firmware for the latest intel i915 drivers

    wget https://01.org/sites/default/files/downloads/intelr-graphics-linux/sklgucver43.tar.bz2
    tar xf sklgucver43.tar.bz2
    cd skl_guc_ver4_3/
    
  5. edit to make sure the properties are correct (use the defaults unless you know what you are doing)

    vim install.sh
    sudo sh install.sh
    
  6. if you have an NVME SSD, the latest boot images don't load the nvme module by default so you may get the dreaded, unresolvable

    ALERT! /dev/disk/by-uuid/##### does not exist.
    

    which drops the bootload down into busybox. The solution is to load the nvme kernel module for the boot image:

    sudo vim /etc/initramfs-tools/modules
    

    add

    i915
    nvme
    

    as the last lines (I added the i915 module for giggles)

  7. rebuild the boot images

    sudo update-initramfs -u
    sudo update-grub
    
  8. follow step by @yancysmith

    sudo apt-get install firmware-b43-installer

    install the latest firmware deb

    sudo dpkg -i linux-firmware_####_all.deb

  9. follow the steps from the arch linux wiki to install the Bluetooth firmware

  10. reboot and rejoice!

Note: you can follow many previous articles to make the machine dual boot windows 10 and Ubuntu nicely without reinstalling windows.

  • I followed Ray answer (answered Jan 19 at 18:37) but I lost the wifi after reboot. So I follow it again using the kernel from <pre> kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-rc2-wily </pre>and now everything is fine. Thanks Ray – user502231 Feb 5 '16 at 15:25
  • I followed your excellent guide and everything seemed to work ok. But when I reboot Ubuntu just boots into a black screen. Any ideas? – Mellson Feb 24 '16 at 13:07
  • I tried with a release candidate of linux kernel 4.5 - then it worked. Thanks for the guide! – Mellson Feb 24 '16 at 13:46
0

I did most of what was mentioned above except adjusting grub, which got me closer to my wifi working but not completely. I was able to use my phone as a hotspot through bluetooth to grab Internet in the meantime.

I then stumbled on this post http://blog.friimaind.it/03/01/2016/installare-ubuntu-15-10-gnome-su-dell-xps-13-9350/ (it's in Italian) and it mentioned this file: /etc/modprobe.d/blacklist.conf. Please sudo gedit /etc/modprobe.d/blacklist.conf or vi if you choose and check which modules are blacklisted.

Whatever you do, please check this file to see what kernel modules are blacklisted. PLEASE DO THIS!

It turns out that the bcmwl-kernel-source driver was blacklisted in favor of firmware-b43-installer and b43fwcutter. Jumping into synaptic, uninstalling the bcmwl-kernel-source driver, and installing both 'firmware-b43-installer' and 'b43fwcutter' as well as rebooting is what worked for me.

Take note, this is after I updated my firmware to the latest one dell has of 2/2/2016, which you can find here: wget http://downloads.dell.com/FOLDER03502638M/1/XPS_9350_1.2.3.exe then you want to copy: sudo cp XPS_9350_1.2.3.exe /boot/efi. You then jump into your bios at start (F2 for me) scroll down to bios flash update and do what you gotta do.

Then I upgraded to 4.4 and the rest of it except the grub stuff. I don't mess with grub unless there is no other way. I also upgraded from Gnome 3.16 to 3.18 since I was using my phone as wifi, which killed the refusing to shutdown bug although that has again raised its lovely head.

Good luck.

protected by Community Feb 8 '16 at 15:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.