1

After installing Ubuntu server 15.10, I am unable to reach the Internet and do not have an IPv4 address. ifconfig only shows lo, but if I type in ifconfig -a, it also shows enp1s0f0, which matches up to the internal ethernet port, but it doesn't have an IP address. I skipped around the steps in the installer, though I did auto-configure DHCP...

As far as I can tell, "enp1s0f0" seems to correspond to virtual machines, on CentOS/Red Hat, and I'm not sure why it's this instead of eth0...

I have tried renaming it to eth0 (fwiw), but a reboot wiped that out. I also tried adding auto-config code to /etc/network/interfaces, but no luck with that, either.

EDIT: Here's the interfaces file, more or less:

"# The loopback..."

auto lo

iface inet loopback

"# eth0"

auto enp1s0f0

iface enp1s0f0 inet dhcp

Also, I unplugged the Ethernet and plugged it into a Thunderbolt to Ethernet adapter, which Ubuntu recognizes, still no Internet... Plugged it back into internal Ethernet port, now Internet works. I don't know why. I'd still like to know about the enp1s0f0 interface, why it's not "en0" and how it's different.

  • Please edit your question to show your /etc/network/interfaces file. – chili555 Dec 15 '15 at 15:36
  • Does sudo dhclient -4 -v enp1s0f0 allow you to get an IP address at all? – Thomas Ward Dec 15 '15 at 15:57
  • Also, Ubuntu now follows the Predictable Network Interface Naming standard, too. (Details on the standard, from freedesktop.org) – Thomas Ward Dec 15 '15 at 15:58
  • Ah gotcha, I figured it was a new thing in 15.10, I just didn't know what to search for (now I know PNIN is a thing!) – jimmyco2008 Dec 15 '15 at 16:08
  • I am able to get an IP address now, I'm not sure why I wasn't before. Thanks for your assistance. – jimmyco2008 Dec 15 '15 at 16:10
0

As Thomas W mentioned, the naming scheme (enp1s0f0) replaced the old one (en0) in 15.10 and it is not indicative of any issues.

I wish I knew exactly what I did to get an IP address (and therefore on the Internet), but I make those edits to the interfaces file (the part for "en0"), rebooted (still no luck), plugged in a Thunderbolt to Ethernet adapter (still no luck), plugged the ethernet cable back into the internal Ethernet port, had internet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.