I'm backing up some files from my wife's computer (iMac) to my file server (Ubuntu). I'm using an external drive to which I've previously copied some of the files but I've since decided to use rsync. I have enabled remote access on the iMac and have no problem connecting to it to fetch files, rsync does what it should.

The problem is that some of the directories appear twice when I list the contents, the only visible difference being the permissions. drwxrwxrwx 4 zarkov zarkov 4,0K dec 14 19:28 110417 Trädgården drwxr-xr-x 4 zarkov zarkov 4,0K mar 12 2012 110417 Trädgården

Needless to say I don't want to have duplicates filling up my backup drives but how do I know which one is removed if I cd 110417\ Trädgården and rm *, I don't want it to be recreated next time I run rsync. I can't tell the folders apart in Unity either.

I guess I could delete both folders and re-run rsync but some of the folders are pretty big so I'd rather not.

I'm perfectly aware that using spaces and non-English characters in folder names is not adviseable but that's how the missus wants it and has done it for many years. Unfortunately it seems only these folders are duplicated, other folders without non-English characters are not duplicated...


  • 1
    Did you consider using the --delete option with rsync? – Jean-Marie Dec 15 '15 at 1:23

It sounds like you're looking for the --iconv option of rsync since you're dealing with two different filesystems (e.g. your mac and your ubuntu server).

Search the web, see the docs, or see here and here.

For the permissions, make sure you're using the -p switch to preserve permissions.

|improve this answer|||||
  • Thanks, it does indeed look like iconv is involved. Unfortunately OSX comes with an old version of rsync that doesn't support iconv and upgrading seems to be quite a pain. I'll give it a try but if I can't get it to work, I'll have to do with @Jean-Marie 's suggestion to use the --delete flag and resync the folders. – Zarkov Dec 15 '15 at 9:29

There seems to be a bug with non English characters - you might want to report this.

As an alternative, I'd suggest you either check out Crash Plan for backups (IMO it's easier to use etc)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.