0

I was trying to install ubuntu server 14.04.3 as a guest on KVM as referred in this link

I made sure that the guest server doesn't have network. Following command used for installation:

sudo virt-install -r 1024  --nonetworks -n test1 --disk path=/var/lib/libvirt/images/st1.img,size=30 --location /home/user/Downloads/ubuntu-14.04.3-server-amd64.iso --extra-args "console=ttyS0,115200n8 serial"

Although the ubuntu installer didn't recognise any network interface it still asked for mirror source and I couldn't continue to install the system.

Thanks.

SOLUTION:

Ubuntu installation process is different when installing using direct connection (Monitor,Keyboard, Mouse)/VNC and when installing via serial port (Console). It looks like that there is a bug when installing via serial port that cause the installation to not permit to continue to rest of the installation when mirror site isn't available. The only way to install ubuntu server as a guest without internet is using VNC. Using VNC there is no need to remove network interface, it just automatically detect that the internet isn't available and skip the requirement to have mirror site available. I have tested is on ubuntu servers 14,15 and 16.

  • Are you using some the normal ISO or the minimal one? – Julen Larrucea Dec 14 '15 at 20:55
  • normal iso server amd_64 – nissan Dec 14 '15 at 21:37
  • Hmm... wouldn't it work for you if you initially enable the network and disable it right after finishing the installation? – Julen Larrucea Dec 14 '15 at 22:27
  • Can't finish the installation since the installation is looking for a mirror server and I can't continue without it. – nissan Dec 14 '15 at 23:05
  • What is the exact step where you get stuck? I am doing it now with the 16.04 daily, and it looks as though it is going to finish fine (currently doing step 24). – Doug Smythies Dec 15 '15 at 0:18
0

The syntax of your virt-install command is incorrect for a no-network installation.

the --location argument requires a network connection for your guest.

The -c or --cdrom= argument needs to be used to specify the iso file name.

I did the no-network test case, but using the a recent 16.04 64 bit server edition daily iso file. It worked fine. This was my command line:

sudo virt-install -n serv64_dev -r 8192 \
--disk path=/media/newhd/serv64_dev.img,bus=virtio,size=50 \
-c xenial-server-amd64-20151214.iso \
--nonetworks \
--video=vmvga --graphics vnc,listen=0.0.0.0 --noautoconsole -v --vcpus=4

Make sure that you have downloaded the correct iso file, and verify the md5sum. Examples:

$ ls -l xenial-server-amd64-20151215.iso
-rw-rwxr-- 1 doug doug 752877568 Dec 15 07:45 xenial-server-amd64-20151215.iso
$ md5sum xenial-server-amd64-20151215.iso
e10efef1980fb712e7dfd8d79d6542c2  xenial-server-amd64-20151215.iso

Now, I compare with the list here, copied below:

e10efef1980fb712e7dfd8d79d6542c2 *xenial-server-amd64.iso
994dd089239adca6421d5deeed528a0b *xenial-server-amd64.squashfs
e28ecd7acc603a903e1877ad6f11bcbd *xenial-server-i386.iso
f6a6a89b2acbe8af285761ddc8545fa0 *xenial-server-i386.squashfs
04bf8218848474c1b305f0bf010990e3 *xenial-server-powerpc.iso
3da7885f81135632443c27ca7b83ef6c *xenial-server-powerpc.squashfs
21f874ed087e92a45c40afebef71a12f *xenial-server-ppc64el.iso
d7435980bc32b3e3962d6a8400e3dea3 *xenial-server-ppc64el.squashfs
86c6c2dadf39cc317f2e1a828ccbb401 *xenial-server-s390x.iso
65e71b1f0eb45f6fc0739c2d0659f99b *xenial-server-s390x.squashfs

Observe that the my checksum agrees with what is listed on the web site.

|improve this answer|||||
  • Download the same iso and got the same error. Since it's installation via console instead of "-c" used "--location" and --extra-args "console=ttyS0,115200n8 serial". This is the only major difference i can see between the command lines. without this I can't get console to do the installation. – nissan Dec 15 '15 at 7:25
  • What version of Ubuntu is your host running? I am running 14.04.3 server edition 64 bit on my host. What step of the test case are you on? – Doug Smythies Dec 15 '15 at 7:30
  • The host is 14.04.3 server 64 bit edition. Tried to install 14.x,15.x and 16.x server 64bit as guest, for each of the installations I reach the same step. I reach the ubuntu archive selection step and can't continue after it since internet isn't available. – nissan Dec 15 '15 at 7:41
  • I am confused. There is no "ubuntu archive selection" step. At what step of the test procedure of your link do you get these directions? Give a step number reference. Your iso file is 752877568 bytes, correct? – Doug Smythies Dec 15 '15 at 7:47
  • There is "ubuntu archive selection" step, When selecting one of the archive sites (i.e. us.archive.ubuntu.com/ubuntu/) I get archive error since the server isn't connected to the internet and I can't go forward after this step. correct, the size of the xenial server version is 725614592 bytes. – nissan Dec 15 '15 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.