1

After running a routine update and rebooting, my computer running Ubuntu 14.04 is now completely unusable. The lightdm screen comes up and accept my password, but it immediately redirects to itself.

Googling shows this is a common bug and no one has really figured out a solution. I tried all the common fixes, including:

  • checked perms of ~/.Xauthority, owned by me
  • checked ~/.xsession-errors of clues, all I see is

    init: at-sp12-registryd main process ended, respawning init: at-sp12-registryd respawning too fast, stopped init: gnome-session (GNOME) main process terminated with status 1

  • checked /var/log/auth.log for clues, saw:

    lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory

    Researching this showed it's a normal error and just means I'm not using KDE, but I tried installing pam_wallet anyways. This made the error in the log go away, but I still can't login.

  • checked my ~/.profile, ~/.bashrc, ~/.bash_aliases for any includes and malformed lines that might be breaking my login, but found nothing

  • sudo apt-get update; sudo apt-get upgrade; sudo apt-get dist-upgrade; sudo reboot
  • tried logging in to Gnome-Shell and Unity, neither work
  • logged in as guest, which worked

but none of these worked or helped me shed light on the problem.

What else might be causing this?

0

The problem is a bug in Gnome-Shell that causes my preferences file to become corrupted, which then can't be loaded and causes Gnome-Shell to crash and bump me back to the login screen.

The workaround is to delete my preferences file:

rm ~/.config/dconf/user

and then reboot. I lose all my customizations but at least I can login.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.