5

The GUI loads to input the decryption password, but when I type, the characters appear in the top-left of my screen, as though I was typing at a console without a command prompt.

Forcing power-off and rebooting allows access to the grub menu, from recovery mode I can type my decryption password without the GUI, and from recovery, I can resume booting.

  • Same problem on 15.10, kernel 4.2.0-26 – jaywink Jan 21 '16 at 18:37
4

So you don't have to use recovery mode every time:

  1. Open a console and type the command

    sudo gedit /etc/default/grub
    
  2. Look for the line with

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    
  3. and change it to

    GRUB_CMDLINE_LINUX_DEFAULT=""
    
  4. Then update the grub bootloader with the command

    sudo update-grub
    

tested using Ubuntu 16.04 LTS


I have caused the same problem on my own system by using this guide: Fix low resolution grub and splash screen with Nvidia drivers on Ubuntu 14.04, which says:

  1. Edit grub:

    GRUB_GFXMODE=1280x1024
    GRUB_GFXPAYLOAD_LINUX=keep
    
  2. and update the bootloader

    sudo update-grub
    
  3. Then, create a file (named splash)

    sudo nano /etc/initramfs-tools/conf.d/splash
    
  4. Fill it with the following line

    echo FRAMEBUFFER=y
    
  5. and run the command

    sudo update-initramfs -u
    
0

I had the same problem with a fresh install of ubuntu 16.04.1

For those who have the same version of ubuntu I can say that you can fix it by doing:

sudo apt-get update
sudo apt-get dist-upgrade

After the next reboot the password field is focussed an you are able to type your password.

Just performing an usual "sudo apt-get upgrade" will not work!

Hint: For those who are not familiar with "dist-upgrade": It does not upgrade to the next distribution (i.e. ubuntu 16.10). The difference between these two commands is explained here.

0

While @mat's answer technically worked for my (Kubuntu 17.10) system, it resulted in very poor graphic performance.

The solution that worked better for me was to uncomment the

GRUB_TERMINAL=console

line of /etc/default/grub, as it kept the boot splash almost as nice as the plymouth one, and more importantly didn't trash my graphic performance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.