1

Using Ubuntu 15.04 on a desktop that has onboard Intel graphics. Recently installed add-in card with Nvidia GeForce GT-730.

I'm unacquainted with Nvidia drivers and wasn't aware of the complexities... After considerable trouble in trying to install nvidia proprietary drivers from the Nvidia web site, and losing my graphics capabilities in the process, I realized that isn't the right thing to do.

So I switched to the apt package in http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu. Installation of the most recent driver pacakge (sudo apt-get install nvidia-358) runs successfully and does not report any errors. However, after a reboot I still don't get the nvidia driver - it seems that the nouveau driver is still being used.

I have also tried earlier packages, the results are the same.

Here are some technical details...

Xorg.0.log contains the follwing lines which suggest an error:

[    27.573] (EE) [drm] KMS not enabled
[    27.573] (EE) No devices detected.
[    27.573] (==) Matched nvidia as autoconfigured driver 0
[    27.573] (==) Matched nouveau as autoconfigured driver 1
[    27.573] (==) Matched modesetting as autoconfigured driver 2
[    27.573] (==) Matched fbdev as autoconfigured driver 3
[    27.573] (==) Matched vesa as autoconfigured driver 4
[    27.573] (==) Assigned the driver to the xf86ConfigLayout
[    27.573] (II) LoadModule: "nvidia"
[    27.573] (WW) Warning, couldn't open module nvidia
[    27.573] (II) UnloadModule: "nvidia"
[    27.573] (II) Unloading nvidia
[    27.573] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    27.573] (II) LoadModule: "nouveau"
[    27.573] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    27.573] (II) Module nouveau: vendor="X.Org Foundation"
[    27.573]    compiled for 1.17.1, module version = 1.0.11
[    27.573]    Module class: X.Org Video Driver
[    27.573]    ABI class: X.Org Video Driver, version 19.0

I have /etc/modprobe.d/nvidia-358_hybrid.conf which contains the following

# This file was installed by nvidia-358
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

lspci -v | grep VGA outputs

01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1) (prog-if 00 [VGA controller])

glxinfo | grep -i vendor outputs

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.

And here is the "Additional drivers" tab from "Software and Updates": The "Additional drivers" tab from "Software and Updates"

Any help would be greatly appreciated! let me know if more details are needed.

Edit: output of lspci -nnk | grep -A3 VGA

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 730] [10de:1287] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:850c]
01:00.1 Audio device [0403]: NVIDIA Corporation GK208 HDMI/DP Audio Controller [10de:0e0f] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:850c]
  • Not really sure what you want help with. Do you, in fact, know the nouveau driver is used? Try lspci -nnk | grep -A3 VGA for some reassurance. – mikewhatever Dec 13 '15 at 23:38
  • I reckon nouveau is used and nvidia isn't, based on the content of Xorg.0.log above. Added requested output too – laugh Dec 15 '15 at 15:54
0

I gave up and installed 14.04 LTS... that "solved" the problem - the nvidia card was detected during installation and I got the correct drivers. The default driver was nouveau, but the proprietary nvidia driver was also installed and I easily switched to it. After reboot I got 3d acceleration (the difference can't go unnoticed!) and dual monitor support with no issues.

Luckily it is a wubi installation so I could install alongside the original OS and then mount the original partition and copy whatever I needed... but I admit this solution sucks. I'm posting it just to let other miserable souls know it works.

If anyone has a better answer please add it. If this is the only answer, I would advise against trying to install new nvidia boards into existing 15.04 systems (or on any existing system? Perhaps new 15.04 systems too? I couldn't find any success stories...)

-2

Have you tried this:

 sudo apt-get install nvidia:i386
 sudo apt-get update
 sudo apt-get upgrade

and it might work fine this way.

  • 1
    Isn't fglrx the driver for ATI? I'm trying to install an Nvidia card. – laugh Dec 15 '15 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.