7

I have problem watching twitter embedded videos. I got this error message: "This browser does not support video playback."

Here is an example

enter image description here

I have Firefox version 43.0.

6
  • Try wget http://bit.ly/1Oq3FNN -O Tesla.mp4 see if you can play the video on your desktop. – Alex Lowe Dec 13 '15 at 20:42
  • @Alex I could watch the downloaded file with firefox - gecko player – laplasz Dec 13 '15 at 22:48
  • Do you have flash installed? I was able to watch in my firefox. – Muzaffar Dec 13 '15 at 23:49
  • @Muzaffar I dont think that is flash. But i have it anyway. I have adblock blugin but even it is disabled I got this error. – laplasz Dec 14 '15 at 7:58
  • 1
    @Parto Are there any related errors/warnings in the browser's web console? (You can open it by going to Tools -> Web Developer -> Web Console. You also need to refresh the page after you open to see if there's any issue) – Dan Jan 21 '16 at 16:44
9

You should -

  1. make sure that gstreamer1.0-libav plugin is installed

  2. then in firefox address bar go about:config, search mediasource & enable media.mediasource.webm.enabled & media.mediasource.enabled

That should allow playback on twitter as long as the 1st. 2 mentioned below are not enabled or you enable all 3

If you want full coverage in Firefox as seen in https://www.youtube.com/html5, (all 6), then in about:config in addition to above search media & enable media.fragmented-mp4.exposed & media.fragmented-mp4.ffmpeg.enabled & needed to not break facebook media.fragmented-mp4.gmp.enabled

As they say proof is in the pudding -

enter image description here

6
  • Aren't media.mediasource.webm.enabled & media.mediasource.enabled enabled by default? Mine are and I don't recall changing them. – Elder Geek Jan 22 '16 at 18:50
  • They are in 43 but not in 42. Whether when upgrading they get enabled not sure, will ck. in 16.04. The other issue could be that if one enabled the other mentioned for full mediasource support for youtube then it breaks that facebook thing if the gmp on isn't enabled, at least as seen here. – doug Jan 22 '16 at 20:10
  • Ok, just checked in 16.04. When upgrading to 43 your existing profile does get those 2 enabled. So the issue for Parto could be, not on 43, some errant plugin/ext. or that he/she has those other ones enabled that break facebook. Here it had nothing to do with other plugins/ext., simply as described above to get rid of the not supported, ect. – doug Jan 22 '16 at 20:18
  • Interesting. Checked mine in 14.04 and they were enabled by default. – Elder Geek Jan 23 '16 at 21:53
  • fixed it for me in 15.10 – ihadanny Mar 28 '16 at 21:09
2

You can use Pepper Flash in firefox. Pepper Flash is basically Chrome's Flash API. Chrome has this API installed by default (You might notice this when you have a fresh install of Windows/Linux and Chrome doesn't need to install flash while other browsers do).

Here are the steps:

  1. Open terminal by clicking the Ubuntu logo, the Super key or press Ctrl+Alt+T
  2. Type or copy in
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
  1. Install google-chrome from it's website or use the chromium way in the link below (The reason you install Google Chrome is for the freshplayerplugin to recognize the Pepper Flash in Chrome and load it into Firefox)

Open firefox and go to about:plugins. This is what you should get (notice the flash version): about:plugins

Uninstall Linux Flash by doing

sudo apt-get purge flashplugin-installer adobe-flashplugin adobe-flash-properties-gtk adobe-flash-properties-kde

Source: Can I use Chrome's Pepper Flash with Firefox?

7
  • Still facing the same issue - 'This browser does not support video playback.' This is my test link: twitter.com/KenyanTraffic/status/689330954071076864 – Parto Jan 19 '16 at 7:10
  • @Parto do sudo apt-get install ubuntu-restricted-extras and do sudo apt-get purge flashplugin-installer adobe-flashplugin after that. – dat tutbrus Jan 19 '16 at 10:16
  • Oh and just for sure you can install Java by doing sudo apt-get install icedtea-plugin – dat tutbrus Jan 19 '16 at 10:17
  • I already have ubuntu-restricted-extras and already purged flas-plugin – Parto Jan 19 '16 at 10:32
  • @Parto How about Java? Anyway try to install this extension (addons.mozilla.org/en-US/firefox/addon/…) and change the UA to Chrome. – dat tutbrus Jan 19 '16 at 10:40
1

I have just updated Firefox to version 43.0 and now the video is supported and playable.

2
  • 1
    I'm running FF 43.0 on Ubuntu 14.04, and I've applied all available updates, but I still have this issue. – mc0e Jan 9 '16 at 11:34
  • Firefox 43.04 also has this issue with the adblock plugin installed. – Elder Geek Jan 21 '16 at 16:09
1
+50

This problem is definitely add-on/extension related.

Restarting with add-ons disabled in Firefox safe mode resolves the issue. Note that simply disabling or removing ad block plus does not work. How: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

In my case I had flashblock installed and disabling it from firefox addon manager did the trick. as seen below:

flashblock-disable

Sources: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Testing

3
  • Same case here. I had installed flash-block. Is there a way to have flash block enabled on other sites but disabled on twitter only, whitelisting doesn't work. – Parto Jan 22 '16 at 6:52
  • Got it, add the following url in the whitelist of flashblock amg.twimg.com – Parto Jan 22 '16 at 7:01
  • @Parto the whitelisting of amg.twimg.com didn't work for me when visiting twitter.com/TeslaMotors/status/676125794121474048 as linked in the OP question. Rolling back edit. – Elder Geek Jan 22 '16 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.