1

I clicked on a normal system update and it asked me to reboot my computer, so I did. After the reboot, there's no sound. Mute/unmute button doesn't do anything (even the notification for volume up/down doesn't appear). It gets weirder

This is my sound settings window. No devices are listed in Output or Input: Sound Settings Window Screenshot

When I ran VLC to see if maybe YouTube was the problem, there was a pop-up error:

Audio output failed: The audio device "default" could not be used: No such file or directory.

Here's my dmesg | grep snd output:

[    4.536437] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC3223: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    4.536442] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.536445] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    4.536447] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    4.536449] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    4.536452] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x19
[    4.536455] snd_hda_codec_realtek hdaudioC1D0:      Headphone Mic=0x1a
[    4.536458] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
[    5.521447] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

And pulseaudio control (pavucontrol) only has this inside:

Connection to PulseAudio failed

"...This is likely because PULSE_SERVER or default-server in client.conf is misconfigured...."

I followed a few other posts such as this and this but nothing. Something got messed up and I can't figure what it is :/

Thanks in advance :)

1

So, I fixed it myself after following the instructions here

It turns out something was wrong with either alsa-base or pulseaudio. purging them and reinstalling solved the problem:

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio

Now the hotkeys for volume up/down won't work. I tried setting them to their defaults by

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up

but that didn't work, so I renamed the .gconf home folder and rebooted. Everything is back in working order now :)

mv .gconf .gconf_backup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.