1

This question already has an answer here:

I've installed Ubuntu 15.10 on a new Dell Precision 5510 from a Live USB stick. I used the "Try without install" mode, and from there installed Ubuntu to the hard drive. During the install, the touchpad worked. However, in the newly installed system, the Synaptic touchpad isn't registering anything.

I've done a bit of digging, and I can confirm the following:

  • The kernel sees the touchpad. xinput list lists the touchpad.
  • evtest does see any events from the touch pad.

When I run xinput list, I get the following:

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ A4Tech USB Mouse                          id=11   [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎜   ↳ DLL06E5:01 06CB:7A13 UNKNOWN              id=17   [slave  pointer  (2)]

Now doing further digging, I've established that id=15 and id=17 are both trying to hog the touchpad, and as such, it's not working.

I can see that the touchpad is recognised in Settings > Mouse and Touchpad, and that options like disabling the touchpad, etc. are also present, and the touchpad is "enabled".

Is there any way to solve this? Can I just disable the UNKNOWN touchpad? I'm not a linux expert, so might need pointers on basics. Any help is appreciated.

marked as duplicate by Pilot6, Ravan, David Foerster, hg8, Charles Green Dec 17 '15 at 15:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

The laptop is pretty much a XPS 9550. I've found using that for support queries is more helpful.

To fix the buggy i2c_hid device:

echo "blacklist i2c_hid" | sudo tee -a /etc/modprobe.d/blacklist.conf
sudo depmod -a
sudo update-initramfs -u
reboot

Taken from: http://ubuntuforums.org/showthread.php?t=2301071 Which has a bunch of other tips to help.

Alternatively, I've found if you fully shut down and power off between reboots, the trackpad works.

  • Ended up back on Windows due to some other driver issues (cpu graphics driver not ready, and thermals mean laptop always running hot...I believe next Ubuntu LTS in April is likely to resolve this). Your solutions seems be target the issue I saw, hence accepting. Thanks. – ashic Dec 17 '15 at 9:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.