1

I have been trying to build applications from the source and they compile perfectly. But when I go to run them, I get this error: This program failed to start because it could not find or load the Qt platform plugin "ubuntumirclient". Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, mirserve, wayland-egl, wayland, xcb. Reinstalling the application may fix this problem. I am running xubuntu 15.10. Any clues as to why this might happen?

0

You are dealing with a Mir library on Xubuntu.

Mir is a very new technology, and is being developed primarily on Unity7 with the Ubuntu SDK, which means that it is pivotal for Canonical Developers to ensure that Ubuntu 15.10 will not have these issues. If you switch to Ubuntu 15.10, you will have the native and recommended developer environment, and subsequently, this should take care of all these dependency issues.

  • Is there any way to get rid of the Mir library so that I can just use xubuntu. Note: I get the same problem when I download the (fully compiled) application telegram and try to run it. – user277907 Dec 12 '15 at 22:50
  • Just curious; did you try any of these dependencies: i.imgur.com/qQtgijG.png – Akiva Dec 13 '15 at 1:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.