2

I seem to be having problems with screen tearing on my Intel nuc5ppyh(n3700 quadcore) with intel integrated graphics. I'm using ubuntu 15.10 with gnome3 but the problem consists in unity or xfce as well. It's noticable when scrolling through webpages, watching fullscreen HD videos through pipelight, html5 or a local file.

I have tried the following to try and fix my problem:

  • Installed latest intel graphics stack from 01.org

  • My config file (/etc/X11/xorg.conf.d/20-intel.conf) looks like this:

    Section "Device"
    Identifier "Intel Graphics"
    Driver "Intel"
    Option "AccelMethod" "sna"
    Option "TearFree" "true"
    Option "TripleBuffer" "true"
    Option "MigrationHeuristic" "greedy"
    Option "Tiling" "true"
    Option "Pageflip" "true"
    Option "ExaNoComposite" "false"
    Option "Tiling" "true"
    Option "Pageflip" "true"
    EndSection
    

I've decided to disable the tearfree and triplebuffer options, they do not have any result on my screen tearing but increase buffer times specifically on pipelight streams.

Furthermore I have tried the fix described in this link: http://www.rottenrei.be/posts/2014-12-23-fixing-ubuntu-s-screen-tearing-on-intel-hd-graphics/

and supposedly this package should have cleared my tearing as well but to no avail: https://launchpad.net/ubuntu/wily/+source/xserver-xorg-video-intel

I'm not really an expert at drivers and such as it comes to ubuntu, so don't expect me to fully understand the answers that may be given to me. English is also not my native language so expect some level of discrepancy.

Thanks in advance!

2

I was able to eliminate screen tearing by enabling DRI3 with SNA acceleration. According to the link below, option "TearFree" "true" is not necessary with option "DRI" "3".

https://wiki.archlinux.org/index.php/intel_graphics#Tear-free_video

0

Try to install and use Compiz windows manager. It works for me.

  • 1
    Fixed my tearing by finding and editing the /usr/share/X11/xorg.conf.d/20-intel.conf instead of /etc/X11/xorg.conf.d/20-intel.conf – archimedes Dec 12 '15 at 18:44
  • 1
    @archimedes You should post that as an answer, then accept it yourself. Yes, you can answer your own question. – clearkimura Dec 12 '15 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.