1

vim-gtk and vim-gnome both have libruby1.9.1 as a package dependency (in trusty), which in turn depends on ruby1.9.1 and I fear doing sudo apt-get install vim-gtk will cause commands such as irb and rails to invoke 1.9.1 stuff. What is a good way to install gvim without tampering with my hard-won ruby setup?

====8<----

EDIT:

As advised by A.B. in comment below, I checked out "I installed a program by getting its source code, and then running sudo make install; how to make apt-get know about it?"

As suggested in the answer to that question, i tried sudo checkinstall -D make install in the directory containing the Makefile for Ruby 2.2.3. Checkinstall informs me that:

**********************************************************************

 Done. The new package has been installed and saved to

 /home/xxxx/Downloads/software/ruby-2.2.3/ruby_2.2.3-1_amd64.deb

 You can remove it from your system anytime using: 

      dpkg -r ruby

**********************************************************************

This is a nice amenity, but apparently doesn't get libruby, ruby, etc. into the already-satisfied-dependencies list:

$ sudo apt-get install vim-gtk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libruby1.9.1 ruby ruby1.9.1
Suggested packages:
  ri ruby-dev ruby1.9.1-examples ri1.9.1 ruby1.9.1-dev ruby-switch cscope
  vim-doc ttf-dejavu
The following NEW packages will be installed:
  libruby1.9.1 ruby1.9.1 vim-gtk
The following packages will be upgraded:
  ruby
1 upgraded, 3 newly installed, 0 to remove and 75 not upgraded.
Need to get 3,739 kB/3,780 kB of archives.
After this operation, 4,951 kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

Is it significant that 1.9.1 is part of the package name itself (rather than a version number that applies to the package) in the case of libruby-1.9.1 and ruby1.9.1? It also says the package ruby will be upgraded. I fear it will be downgraded. I also tried sudo dpkg -i ruby_2.2.3-1_amd64.deb (the debfile having been created by checkinstall) followed by trying to install vim-gtk.

====8<----

FURTHER EDIT:

Tried adding the alternative PPA per @muru's suggestion. Then sudo apt-get install vim-gtk, which pulls in ruby1.9.1 as a dependency, but ruby -v shows ruby 2.2.3p173 (2015-08-18 revision 51636) [x86_64-linux], so I think I'm probably good to go.

$ sudo add-apt-repository ppa:gwibber-daily/ppa
[sudo] password for xxxx: 
 Daily builds of Gwibber trunk
 More info: https://launchpad.net/~gwibber-daily/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpjnmo3n3s/secring.gpg' created
gpg: keyring `/tmp/tmpjnmo3n3s/pubring.gpg' created
gpg: requesting key 72D340A3 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpjnmo3n3s/trustdb.gpg: trustdb created
gpg: key 72D340A3: public key "Launchpad PPA for gwibber-daily" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
$ sudo apt-get install ruby
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  vim-gui-common
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  libruby1.9.1 ruby1.9.1
Suggested packages:
  ri ruby-dev ruby1.9.1-examples ri1.9.1 ruby1.9.1-dev ruby-switch
The following NEW packages will be installed:
  libruby1.9.1 ruby ruby1.9.1
0 upgraded, 3 newly installed, 0 to remove and 18 not upgraded.
Need to get 0 B/2,686 kB of archives.
After this operation, 12.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
$

Seems apt-get is still offering ruby1.9.1 et al.

marked as duplicate by A.B., David Foerster, Eric Carvalho, hg8, TellMeWhy Dec 14 '15 at 10:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.