I am trying to install Open MPI. I downloaded the archive and extracted the folder to /home/. I cded there and entered ./configure --prefix="/opt/openmpi" and got this error:

./configure: line 4840: config.log: Permission denied
./configure: line 4850: config.log: Permission denied

I tried the following:

  • ls -l configure which gives -rwxrwxr-x 1 root root ... configure
  • df -h .. I'm on /dev/sda6
  • grep '\s/home/\s.*noexec' /proc/mounts yields no results
  • Prepend the command with sh

I try to avoid using sudo to install this. What can I do?

  • 1
    I think you do not have the rights to write to /home/ as non root user and if configure is root:root maybe that the directory have the same rights. So you have to chown all the directory or run configure as root... – LilloX Dec 11 '15 at 14:47
  • 1
    IMHO it would be better to extract it to your actual $HOME i.e. /home/username/ – steeldriver Dec 11 '15 at 15:02
  • @steeldriver I tried that as well. The location in /home is just the last place I tried before asking. – kleinfreund Dec 11 '15 at 15:02
  • How are you extracting it into your $HOME? If you're using sudo ... don't – steeldriver Dec 11 '15 at 15:03
  • @steeldriver I only used sudo for the chown command. I copied the directory via GUI. – kleinfreund Dec 11 '15 at 15:05

As suggested by @Lillox I needed to chwon the directory (e.g. /home/openmpi-1.10.1).

sudo chown -R user: .

(After the : the user-group is left out so this command uses the default user group.)

After that I continued installation with these commands:

./configure --prefix="/opt/openmpi"
make all install
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.