I installed the gedit-r-plugin through synaptic and in the past it has worked great. I can't seem to even get the plugin to show up in the Preferences -> Plugins list after updating to 11.10. I'm guessing this is because of the switch to gtk3 but I'm at a loss for what to do. What can I do to resolve this and get the ability to work with R nicely through gedit again?


You are correct - the move to GTK3 has broken this plugin.

Fortunately - this has been resolved in the very latest code available in SourceForge.

If you want to compile this code, you will need to manually install the plugin as per the Linked Question below.

Unless this plugin gets a SRU - dont expect it to land in the Oneiric repo's. Probably will though for Precise.

Until then - you could always try downloading the GTK3 deb file from the Debian Sid Repo's

to install

First install from synaptic the gedit-r-plugin available in synaptic. This will ensure all dependent packages are also installed.

Then download the Debian Sid .deb (link above)

Install with the syntax:

sudo dpkg -i [filename.deb]

After installation - you should see it appear in the preferences - plugins screen:

enter image description here

Linked Question:

  1. How do I install a plugin for gEdit v3?
  • Looks to provide a really good answer. Thank you! As soon as I can try it out and make sure it works I'll accept it. – Dason Oct 22 '11 at 22:56
  • The Debian Sid .deb didn't work for me. It added the right menus and but none of them produced any of the desired results. When I have some more time I'll try the other method. – Dason Oct 22 '11 at 23:26
  • I finally got it working. Downloading the source and installing it manually worked. If anybody else tries this note that you have to install it into ~/.local/share/gedit/plugins/ and if you try to install to /usr/lib/gedit/plugins/ it will yell at you. – Dason Oct 22 '11 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.