12

My account is an administrator; I'm using Ubuntu 14.04LTS.

I've set a password and set automatic login to OFF, yet when I wake up from suspension or reboot if I just press Enter or type in anything then it logs me in.

How should I proceed?

  • 1
    Have you checked power options? It usually has an option to the effect of "Lock when going for suspend" It differs between dekstop environments I think – Wilhelm Erasmus Dec 10 '15 at 20:14
  • I don't have option, all I have is when lid is closed, when power is critical and when computer is inactive. – Steam gamer Dec 10 '15 at 20:19
  • Do you have any screensavers installed such as xscreensaver? – Organic Marble Dec 15 '15 at 4:38
  • @Organic Marble - xscreensaver is not installed. – Steam gamer Dec 15 '15 at 7:58
8
+100

Easy:

  • Click the gear icon in the top-right corner of your screen:

    Gear icon

  • Click System Settings, then Brightness & Lock:

    Brightness&Lock screen

  • Click the Lock switch until it goes into the On position and ensure the Require my password when waking from suspend is ticked.

Done! ;-)


If that doesn't work:

Create a new user on your system and see whether that user does work. If that's the case (in the below example we'll use steam-gamer and steam-gamer2), just do the following:

  1. Open the file manager
  2. Browse to the /home/steam-gamer directory
  3. Copy (don't move!) all the files from Downloads to /home/steam-gamer2/Downloads
  4. Check you did a good job.
  5. Now delete /home/steam-gamer/Downloads
  6. Go back to step 3 and repeat for Documents, Videos, ...
  7. After a couple of days to allow you to ensure you didn't forget to copy anything, just delete steam-gamer together with it's home directory by issuing the following command:

    sudo deluser steam-gamer --remove-home
    
  • Oh, and you know the drill by now... Don't thank me! If this answer did help, just click the little grey under the "0" now turning it into beautiful green. If you do not like the answer, click on the little grey down-arrow below the 0, and if you really like the answer, click on the little grey ☑ and the little up-arrow... If you have any further questions, just ask another one! ;-) – Fabby Dec 14 '15 at 15:23
  • 1
    The lock switch is turned on,and checked 'Require my password when waking from suspend' but still it doesn't work. – Steam gamer Dec 14 '15 at 19:35
  • @Steamgamer That is usually rare or intermittent, but is a well-known bug: See bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/… for example. – NoBugs Dec 18 '15 at 4:39
3

I like using the terminal:

  1. Enable Screen Lock

    gsettings set org.gnome.desktop.screensaver lock-enabled true
    
  2. Enable Lock on Suspend

    gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend true
    

To disable, use false instead of true.

;-)

2

First make sure you have all the security updates installed. If this is not the issue, check if the problem appears when you log into other graphical environments. You can also test the manual lock with "Ctrl + Alt + L". If you use a screen saver, take a look at this one.

-1

The brute force approach is to hand edit /etc/lightdm/lightdm.conf, adding a # character to the beginning of every line starting with autologin.

  • This is what is in the config file: [SeatDefaults] autologin-user=, only 1 line... – Steam gamer Dec 16 '15 at 7:57
  • Maybe changing that line to just be [SeatDefaults] makes a difference, then? – Ralph Rönnquist Dec 18 '15 at 4:40
  • Rönnquis, that also didn't work, but thanks for contributing. – Steam gamer Dec 18 '15 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.