6

I installed Ubuntu on a Dell XPS 13 laptop that had Windows 10 preinstalled on it. I installed it from a USB flash drive on a partition. When I boot my computer I can only boot into Windows 10 and Ubuntu is nowhere to be seen.

If I boot into my USB then I can see that Ubuntu is installed, but I can't get to it from the BIOS boot menu.

  • This might help you out with your problem. – Alex Lowe Dec 10 '15 at 18:21
  • it doesn't :( i'm not seeing UBUNTU in the boot menu – Haim Dec 10 '15 at 18:34
4

Disable the hibernation mode and Fast Boot in Windows.
Open command prompt as administrator and execute :

powercfg /h off  

Open the legacy version of the Windows Control Panel (not the modern version).
Select Energy Settings, enable show hidden settings and uncheck Fast Boot.
After having done this - shutdown the computer completely - do NOT reboot.
Boot into the BIOS and select Ubuntu as the default operating system to boot.

Update :

In case there is no Ubuntu entry to be found in the BIOS / UEFI settings,
re-install the GRUB boot loader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu installation media - open a terminal and execute:

sudo mount /dev/sdXXX /mnt
sudo mount /dev/sdXX /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sdX
update-grub  

Note:

sdX = disk | sdXX = efi partition | sdXXX = system partition

To identify the partition numbers use GParted - it is included in the Ubuntu installation media.
Boot into BIOS and select Ubuntu in UEFI settings to be the default operating system to boot.

  • Thanks! I can't see Energy Settings in the control panel? – Haim Dec 10 '15 at 18:33
  • @Haim : It is there ... something with energy ... search through the old version of control panel ... maybe fast boot is already disabled after you executed the command. :) – cl-netbox Dec 10 '15 at 18:35
  • 1
    Ok, I restarted and still the boot menu doesn't show UBUNTU – Haim Dec 10 '15 at 18:39
  • @Haim : Did you switch the default operating system to Ubuntu in BIOS / UEFI settings ? :) – cl-netbox Dec 10 '15 at 18:41
  • where would I do that? BTW thanks for trying to help me out – Haim Dec 10 '15 at 20:21
1

I had the exact same problem. What fixed it for me was this: I have 2 different hard drives installed. It took me forever to figure this out but was solved it was changing the boot priority from the first to the second drive. Probably the boot manager for ubuntu was installed on the other drive so it couldn't find it and booted straight into windows.

1

For all the cases when Grub as been successfully installed in the ESP (EFI System Partition) but the installer didn't (or couldn't) change the boot order, users have to do it manually by opening UEFI settings > Boot (the actual menu name could vary) and select Ubuntu as the first boot option. That should boot the Grub menu which in turn allows selecting Ubuntu or Windows.

1

I had a similar issue, and it turned out that the problem was that there wasn't a working driver for my GPU preinstalled on the OS. My solution was to enter Recovery mode. At the GRUB menu press the down arrow key until you select the 2nd entry from the top (the entry with the recovery mode in its description) and then press Enter twice.

Now you should see this Recovery Menu:

enter image description here

Select the network option from the Recovery menu and press Enter.

Select the root option from the Recovery menu, and then use the command line to run ubuntu-drivers autoinstall && reboot to automatically install the proprietary graphics driver.

1

Immediately after the BIOS/UEFI splash screen during boot, with BIOS, quickly press and hold the Shift key, which will bring up a GNU GRUB menu screen. With UEFI press (perhaps several times) the Esc key to get to the GNU GRUB menu screen. Select Ubuntu from the GRUB menu and press Enter.

From Ubuntu open the terminal and type:

sudo update-grub && sudo reboot

If this doesn't work try booting to an ubuntu live session from the USB flash drive that you used to install Ubuntu, and repairing the GRUB bootloader with Boot Repair. From an Ubuntu live session open the terminal and type:

sudo add-apt-repository ppa:yannubuntu/boot-repair  
sudo apt update  
sudo apt install -y boot-repair
sudo boot-repair  

Open the Boot Repair application and select Advanced Options -> Main Options tab -> check Reinstall GRUB and Unhide boot menu as shown in the below screenshot. Click the Apply button. Then reboot the computer with sudo reboot

enter image description here

If the OSs were installed in different modes, dual booting Windows and Ubuntu can't work. If your Windows is installed in BIOS mode, it is recommended to install your Ubuntu in BIOS mode, but if it's installed in UEFI mode, then do the same with Ubuntu. To check if your Windows is installed in UEFI, press the keyboard combination Windows + r then enter the command msinfo32 in the Run window. In the new window that opens up look for the entry after where it says BIOS Mode.

enter image description here
          BIOS vs. UEFI

If you have installed Ubuntu in legacy mode on the same drive with GPT partitioning, you can use Boot Repair's Advanced options to uninstall grub-pc and install grub-efi-amd64. That converts the Ubuntu installation from BIOS boot to UEFI boot, the same firmware as most recently manufactured laptops with Windows pre-installed have.

Converting Ubuntu into UEFI mode

  1. Start Boot-Repair, and select Advanced options -> GRUB location tab.
  2. If you do not see a Separate /boot/efi partition option, this means that your PC does not have any UEFI partition.
  3. If you see a Separate /boot/efi partition option, put a checkmark in the checkbox to the left of it, then click the Apply button in the lower right corner.

    enter image description here

  4. Set up your BIOS so that it boots the hard drive in UEFI mode. The way to adjust this setting depends on the specific model of the computer, but generally this setting is located in the boot priority settings under the Boot tab of the BIOS/UEFI setup utility.

For more information about converting Ubuntu into UEFI mode review https://help.ubuntu.com/community/UEFI in the section about Converting Ubuntu into UEFI mode.

The grub bootloader can also be converted in the opposite direction from UEFI to BIOS. Linux can boot fine from a GPT disk in BIOS mode. See this answer: Convert from EFI to BIOS boot mode

0

Shutdown. Then press F12 on boot and use arrows to choose ubuntu (note lowercase).

Also, you should try shutting down, press F2 to open BIOS/UEFI settings and disable Secure Boot and make ubuntu top priority. Then GRUB can boot Windows.

  • 3
    The problem us that UBUNTU doesn't show in the list of boot options – Haim Dec 10 '15 at 18:33
  • 1
    I had the same problem, because UEFI was pulling up the Windows 10 bootloader not GRUB. – Rick Chatham Mar 24 '16 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.