I have an Intel NUC like box with me (exactly this thing: http://b2b.gigabyte.com/products/product-page.aspx?pid=5445#ov) and trying to get Ubuntu 14.04 LTS installed on it, but for some magical reason it just won't work. It has a 32GB built-in eMMC flash storage and every time I boot the live usb with UEFI and get to the installer it goes fine till a point and I get an input/output error message for some unknown reason or a read-only error for the /target which makes not much sense to me. Once booting the live usb without UEFI can install it, but can't install the UEFI partition not even with boot-repair so can't boot it... argh

Has anybody had any experience installing Ubuntu on eMMC flash? Is there any trick?

(Click image to enlarge)

2 Answers 2


In my experience, eMMC storage devices are poorly supported in Linux. I've got an ASUS P100T that's virtually useless with Ubuntu (I've tried through Vivid) because of similar I/O errors and other problems on its eMMC storage. Sometimes such problems get cleared up with newer kernels, so you might try with Wily, which has the most up-to-date kernel of any Ubuntu release at the moment. Along those lines, it's not clear if you used 14.04 GA (which has a 3.13-series kernel) or one of the more recent point releases, which have more recent kernels. 14.04.3 uses the same kernel as 15.04.

The specs for your device say that it has a bay for a 2.5-inch SSD or HDD. I'm guessing that's a conventional SATA device, although I've not dug too deeply into the specs. My guess is that you'd have much better luck if you plug in such a disk and install to it rather than to the eMMC device.

  • Right, did some digging and found similar answers, guess it would be easier to just install an SSD in it. It has a SATA II connetor, but kinda loose its purpose. Will try with 15.10 tomorrow, tried 14.04.3 so don't expect so big of a difference.
    – Adathor
    Dec 10, 2015 at 17:29

Just to follow this up a little. The key to solve the issue was not to use a newer release like Wily to have a newer version kernel, but to go back a little bit and use an older release. What I did:

  1. Disable compatibility support module in the bios (CSM),
  2. Boot Ubuntu 14.04.1 from USB drive in UEFI mode,
  3. Installation is smooth and no issues at all, no i/o errors, no need for any grub fix or boot-repair although in my case it took a while to finish the installation, probably some bandwidth issues,
  4. Once the system is up did an upgrade and it works fine, 14.04.3.

Thanks for the help and ideas, hope this can help others as well!

  • Is your 14.01.1 32 or 64 bit? And how did you flash the ISO to the USB? Those configurations can also be easily overlooked.
    – chx101
    Jul 31, 2019 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.