2

After installing the proprietary Nvidia drivers (GEForce 730), normal boot hangs during splash loading. Alternate boot selecting Recovery Mode / Resume normal boot takes me to the login screen. The behavior is identical to that described in these other issues:

NVidia driver, normal boot results in blank screen, recovery boot works fine

14.04 LTS only boots through recovery

New install of Ubuntu 15.10. I have literally done nothing but configure my drives and install keepassx2 before Nvidia installation.

I originally tried to install the drivers from Nvidia, but the install never started because I couldn't overcome the problem of nouveau being loaded. So I used the repository instead:

sudo add-apt-repository ppa:graphics-drivers/ppa

to install the 355 driver version.

That is when the current problem started. I also tried using the Additional Drivers app to change the 358 driver version.

I tried following the suggestion in the first referenced issue to slow down boot with a sleep command. But I think our systems aren't identical. I have a lightdm file, not a lightdm.conf file. And instead of exec lightdm it is a paramaterized lightdm start command. I may have done it wrong, since when it didn't work I changed from sleep 2 to sleep 90 with no effect. And by "no effect" I mean it doesn't fix the problem, and when I boot with Recover Mode / Resume it doesn't seem to add 90 seconds to the boot time.

/etc/init.d/lightdm [snip]

else
  log_daemon_msg "Starting X display manager" "lightdm"
#To fix boot hang / starts lightdm too soon
sleep 90
  start-stop-daemon --start --quiet $SSD_START_ARGS \
    || log_progress_msg "already running"
  log_end_msg 0
fi

I also (inadvertently) tried setting the 'nomodeset' parm in grub, in that I had already added that parm earlier while trying to disable nouveau drivers. After I gave that up and went with the PPA installation, the parm was still set. In troubleshooting the current issue, I removed the 'nomodeset' parm from grub, but that hasn't made a difference.

Anyway, the drivers seem to work great...I just can't boot through the normal process. What is failing during boot, and what fix and or workaround can I apply?

1

I found a way to fix this.

Originally I was running a shell script at boot to re-assign update alternatives. For example..

sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/nvidia-352-prime/ld.so.conf
sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/nvidia-352-prime/alt_ld.so.conf

For a separate reason I needed to have a newer kernel so I downloaded the wily 4.2 kernel to my 14.04 system and I noticed I didn't have to run that script any more.

I think this may be that installing this kernel forced rebuilding. I also noticed a DKMS error as well. Obviously this isn't the exact reasoning to the error as I haven't had a chance to investigate it completely.

Perhaps re-installing the kernel and headers might help, or even trying to install the wily kernel. It does have some new upgrades.

You can see the all the options for kernels by searching the repos like so.

apt-cache search linux-image
apt-cache search linux-headers
  • 1
    Thanks, this wasn't exactly the issue, but it put me on the right track. I did in fact have a kernel conflict, but in my case it was because my MBR hadn't updated correctly to boot me from my new boot partition. So everything I was doing to try to configure the running kernel was being ignored, which is obviously important when trying to install the nvidia drivers. Also during the later install of the drivers, I also had the issue with DKMS that I fixed b a) reinstalling kernel headers, and b) installing kernel source into the /usr/src directory. – user480402 Dec 10 '15 at 22:32
  • I will have to look into this further and see if these bugs have been reported because it is clearly a problem a lot of people are having. – Goddard Dec 10 '15 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.