1

The setup.

Stock Ubuntu 14.03 LTS install with MAAS from the CD installed in a kvm virtual machine. I selected the MAAS install on the boot prompt. Then ran update and upgrade. The MAAS server as 4G of ram and 4 CPUs.

So far so good. Got the MAAS website up and running and everything is surprisingly quick. Network configuration is handled by my pfsence router. I can ping the internet and download files from the MAAS. Install the 14.04 LTS image so I can get a node running.

While it downloads, I configure the dhcp for PXE boot on the MAAS server.

Once the download and sync is done, I boot up a virtual machine in PXE to get it to connect. This machine as 2 CPUs and 4G of ram. It boots on PXE without any issue, loads Ubuntu, then shutsdown. However, I never see it as a node in MAAS.

No biggy. I configure it manualy, including the stuff needed for MAAS to be able to make it boot itself, MAC, specs, etc.

Machine boots up as soon as I hit commission note, starts Ubuntu and even gets the right name automatically.

Still says commissioning in Nodes. I wait. It eventually fails. The console as "connection failed" errors to archive.ubuntu.com.

After several retries and checking on the router, it would appear the node never tries to go over the internet to get anything. All other machines on the same network/dhcp server have no issues getting to the net. The machine's IP is fixed and was tested to work with a live cd booting the machine and accessing the internet this way.

Communication between this VM and others is limited by HDD speed in all the tests I have done. While it is commissioning, the disks are 99% idle. So if it is getting files from the MAAS server, it should not be this slow.

I'm a bit at a loss as to what exactly is causing the node to fail like this and would really appreciate some help.

Thanks

  • Tried a few more things. Using the CD to enlist the machine makes it shutdown, but it never appears in the MAAS as enlisted. I've tried this with 2 different VMs and a physical machine. Same result. It also now appears that contrary to what I stated above, booting a machine in PXE to enlist it does not make it shutdown afterward. It just sits at login and never gives any message. This is true with both physical and virtual machines. – Mad Chaz Dec 9 '15 at 18:21
  • I've also tried using the MAAS's dns and dhcp servers while turning the dhcp off on my pfsence router. Same result. – Mad Chaz Dec 9 '15 at 18:32
  • 1
    Issue turned out to have to do with ipv4 vs ipv6. As I do not have IPV6 enabled on my network and the maas proxy defaulting to ipv6 caused things to fail. Editing /etc/maas/maas-proxy.conf and adding "dns_v4_first on" in it fixed the issue. – Mad Chaz Dec 9 '15 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.