34

I had a Compose Key set to right Super (a.k.a. Windows) key using Gnome keybindings. After upgrading, I seem to have lost the Compose Key function. Where can I enable Compose Key? I can't find any option under System Settings > Keyboard.

40

In Ubuntu 18.04 and later, since Ubuntu has now adopted the GNOME Desktop, things are more complicated: there is no longer any way to set the compose key within the regular system settings.

You must first download an entirely separate program, GNOME Tweaks. This can be found in Ubuntu Software or can be downloaded with this command via a terminal:

sudo apt install gnome-tweak-tool

Once Tweaks is installed, run it. Then hit Keyboard & Mouse on the left. In the Keyboard section on the right, an option to enable the compose key can be found. You may need to toggle the switch in the title bar of the window to enable setting the key.

Note that there are still limited options for what key can be set: Scroll Lock, Right Alt, Caps Lock, PrtScn, Right Ctrl, Left Alt, Menu, and Right Super. If you wish to set it to a key not listed, the solution in this answer still works.


In Ubuntu 14.04 and 16.04 go to Keyboard within System Settings. Select the Shortcuts tab, then Typing from the list on the left. Clicking to the right of the Compose Key setting will bring up a menu of different options.

Note that the only options are Right Alt, Right Ctrl, Right Win, Left Alt, Menu, and Caps Lock. If you wish to set it to a key not listed, see this answer.


In Ubuntu 12.04 and earlier, go to Keyboard Layout in System Settings, then hit the Options button on the lower right. You will see one option called Compose key position, where you can set it to Right Win (i.e. right Super).

  • 4
    The Ubuntu 18.04 solution still applies, as of Ubuntu 19.04. – tanius Apr 11 '19 at 12:56
  • @Aibara On my 18.04.3 system, gnome tweaks keeps the compose key setting disabled. – Jonathan Aug 24 '19 at 15:09
  • 1
    @Jonathan Check my solution below to get it to actually enable the setting. – Chuck Adams Nov 19 '19 at 20:28
4

In Ubuntu 13.10

In Keyboard settings window, under Shortcuts -> Typing set Compose key to Right Alt (or other). snap1

3

On Ubuntu 19.10, and likely anything using gnome-tweaks (the current name for gnome-tweak-tool), the UI for enabling the compose key is a little confusing. First, under Keyboard & Mouse, click the "Disabled" button:

disabled button

Then this is where the UI is tricky (and utterly indefensible IMHO). Click the switch widget in the top left of the new window:

switch widget

Once you do that, it'll let you actually change the setting.

2

In Ubuntu MATE 18.04 go to Control CenterKeyboardLayoutsOptionsPosition of Compose key and select your choice for the key.

1

In Ubuntu 12.04 LTS:

  1. Select System Settings... from system menu; snap1

  2. Select Keyboard; snap2

  3. Under the tab labelled Typing click Layout Settings; snap3

  4. In keyboard layout window, click Options... button; snap4

  5. Finally in the Keyboard Layout Options window select Key(s) to change layout and mark the binding of your choice. (I use Shift + CapsLock to toggle the layout.) snap5


Useful link:

Summary:

Using compose key:

  • For ë you press Compose followed by " then e keys.

    (..here you'd have to remember the two character combination)

Using hexadecimal Unicode character code point:

  • Press (and release) Shift+Ctrl+U, then, while underlined u is displayed, enter the hexadecimal Unicode character code point followed by Return or Space.

    e.g. Ctrl+Shift+u followed by 2 6 3 b and then Return or Space for ☻ .

    (..so this one would require you to remember the Unicode number)

0

In order to set up the Compose key you must go to (setting -> keyboard -> layout settings -> keyboard settings -> then go to the typing tab -> press and hold the Compose Key setting -> move you mouse down to select the key you want to assign Compose to. enter image description here enter image description here enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.