25

My laptop recognises external display devices if I connect them before booting the system, but many times it doesn't if I connect while the system is running. In this case, rebooting naturally solves the problem.

Is there a way to force Ubuntu to detect external displays? Opening up the display menu and pressing "Detect displays" does nothing.

4
  • 1
    Video card and driver in use? – dadexix86 Dec 8 '15 at 17:19
  • From lshw -c video: it's Haswell-ULT Integrated Graphics Controller and the driver is i915. – aasitus Dec 8 '15 at 17:53
  • Try logging out, going to a VC (ctrl-alt-F1) and restarting X (askubuntu.com/a/79587/16395). Sometime it works. Without logging out --- I never managed it. – Rmano Dec 8 '15 at 21:13
  • Thanks. I was hoping there'd be a way to do that without logging out. – aasitus Dec 10 '15 at 19:41
20

Actually, you don't need to log out. Simply going to a VC with ctrl-alt-F1, restarting x with sudo service sddm restart and and going back to your graphical interface with ctrl-alt-F7 (or F2) should do it.

This way, you don't lose all your windows...

6
  • 1
    This seems like it would work, since restarting my laptop works, but it doesn't. – TankorSmash Mar 3 '17 at 20:14
  • This trick perfectly solved my problem => a case of replacing the current monitor with a new one while Ubuntu 16.04 LTE is running without reboot/logout. I just had to press Ctrl + Alt + F1 while my old monitor is connected, disconnect it and connect my new monitor, press Ctrl + Alt + F7 and it worked instantly! Thank you so much! – Jim C Apr 19 '17 at 2:35
  • Nice! before this I was kind of frustrated with 17.10. For me actually just doing Ctrl+Alt+F1 and logging back in is sufficient. – Jarno Feb 26 '18 at 17:59
  • I'm also with 17.10, with Gnome replacing Unity. And to get back I used Ctrl+Alt+F2, instead of F7 – Ilia Barahovski Apr 9 '18 at 10:19
  • 3
    In Ubuntu 18.04, it seems the default default graphical interface is F1. So I do Ctrl+Alt+F2, then Ctrl+Alt+F1. – David Oliver May 12 '18 at 13:20
8

To enable all outputs in their default mode, run:

$ xrandr --auto 

For more information, see:

https://xorg-team.pages.debian.net/xorg/howto/use-xrandr.html

2
  • xrandr says the display is disconnected, but it works fine in Windows. – Aaron Franke Dec 9 '18 at 7:49
  • 2
    This one worked for me. My third screen immediately started working. – AFP_555 Sep 29 '19 at 4:37
1

I just encountered this issue with my Dell Latitude E5550 using a port extender and two external monitors.

My problems began when I had a power failure. For silly reasons, I could only plug in one of my two monitors, so I opened up the screen display interface and de-activated the screen that didn't have power.

Awesome!

Once the power came back on the process to turn my screen back on was unintuitive. I couldn't see it in the screen display interface even after rebooting or redocking my laptop.

So I tried $ xrandr --auto and got Ubuntu to extend to "one" screen but duplicate to both of my externals (they are two of the same model). Amusing but not useful.

It was only when I clicked on "1 Built-in display" like in the screenshot below that I was able to select my "3rd" screen and turn it on again.

The Screen Display Interface

Doing this flipped the two screens around for some reason and I had to rearrange them but that was easily fixed!

2
  • lshw -c video doesn't list monitors it lists your drivers. – hugo der hungrige Mar 11 '19 at 10:14
  • 1
    You're absolutely right! I will edit my answer. – Cerberton Mar 12 '19 at 11:04
1

I also have Dell Latitude E5550, I have one onitor via hdmi, and one via usb-c. Then one via usb-c is not detected sometimes, and for me what it works, is unplug/plug the hdmi port in the monitor, while the rest is connected.

1
  • Just solved my issue with Dell XPS 13. – Jatentaki May 13 at 20:22
0

If the external monitor can't be detected by using xrandr --auto, or even by booting to different OS, reboot Ubuntu using a previous kernel. If the computer detects the monitor in the older kernel, you can go back to the latest one without any problems.

I don't know the exact reason why it works, but it definitely worked for me.

1
  • xrandr --auto closed my current GUI sessionn ! But afterwards I could use all 3 Displays: Build in Laptop and two external Display. Displays are connected via USB / DisplayLink – Thorsten Niehues Oct 10 '18 at 8:27
0

Working solution: Disable secure boot in the bios/efi menu.

Hello Everyone, I am coming from a TongFang GK5CN6Z and I had this issue. I noticed it was an issue after having ran the latest updates on Ubuntu. Turns out I had to disable secure boot in order for it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.