0

I'm getting an error of "Permission Denied: torrent-name.iso" about 5 minutes after I add the torrent file, I'm using Deluge on a headless Ubuntu Server 14-04- LTS PPC, Deluge is running with my user and group, when I check the permissions for the Directory and file (/home/tiferrei/Downloads/Incomplete) they are all RWX and owned by my username. Also, if I set the user permissions of the file to RWX again and restart deluge it runs perfectly for 5 minutes (about 20 MB downloaded) and then gives me the same error.

Thank you for your help, Tiferrei

1 Answer 1

0

the permission on the torrent look right and that is fine but what about the permission of Deluge itself?

Does deluge has execute (+x) permission on the location/media where you have your torrent-name.iso?

So, at this stage I'd say you need to check the group ownership of the location, say /mnt/. where the torrent-name.iso is located and add deluge user to that group.

This will do the work, it is not a big deal at the end and if you were just typing the headline of your question to google you will find the answer. It is the second line after yours on google search so you wouldn't need to do a hard search:-)

Good luck

9
  • Yeah I already checked that one but it didn't work, all my Incomplete, Complete and auto add directories are in my home folder, and as I've mentioned Deluge is running with my user and group. Commented Dec 8, 2015 at 17:09
  • why it wouldn't work? apparently you didn't followed properly. deluge has it's own username. pls see in the officiale documentation here: dev.deluge-torrent.org/wiki/UserGuide/Service/Upstart
    – ostendali
    Commented Dec 8, 2015 at 17:15
  • I followed this guide: htpcbeginner.com/install-deluge-web-interface-on-ubuntu-1204 Could you please tell me if this is the correct procedure? Also my torrent file is with permissions as -rwxrwxrwx, is this correct? Thanks Commented Dec 8, 2015 at 17:18
  • this guide creates a workaround of what I just said, instead of assigning deluge user to proper group it is suggesting to run deluge as different user/group. So have you set the correct uid/gid in deluge configuration as suggested? That should be your own uid/gid.....
    – ostendali
    Commented Dec 8, 2015 at 17:22
  • It is supposed to be my username right? If yes, than yes it's with the correct did/gid Commented Dec 8, 2015 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .