1

I've been using ubuntu for a few years now, however this is my first time asking a question on the forums so please let me know if I have not provided enough info.

I'm running 14.04 Home on an Intel® Core™ i5 CPU 661 @ 3.33GHz × 4 with 8GB of ram as a media player/server

Currently, I'm trying to get transmission working with the default download directory on an NTFS drive, mounted at /media/paul/Downloads, but keep getting a permissions error within transmission. I have tried chmod & chown, to find out these commands only work on unix filesystems. It's odd, the permissions of the folder /media/paul/Downloads is drwx------ when it is mounted, and drwxr-xr-x when it is not.

I have also tried the following:

  • Changed the user in the file /etc/init.d/transmission-daemon to root
  • Applied the same options in fstab as my other writeable NTFS drives: nosuid,nodev,nofail,x-gvfs-show
  • Tried rw option, and umask=000 in fstab
  • Also, tried rw,noauto,users,uid=1000,gid=1000,permissions as per this post
  • Several combinations of the last three

This is currently what my fstab file looks like:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=463c5639-f937-46c5-b5a7-67de7b49a999 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=c6621b2e-5383-4031-8bd0-1210e0a79147 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/dev/disk/by-uuid/898d19a1-6214-4331-9a53-6318bd104b8e /mnt/898d19a1-6214-4331-9a53-6318bd104b8e auto nosuid,nodev,nofail,noauto 0 0
/dev/disk/by-uuid/EA8CE9698CE930AD /mnt/EA8CE9698CE930AD auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/0B181B702141B3B7 /media/paul/Movies auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/0E8688030EAF0509 /media/paul/Games auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/89cac2d7-665f-4fc7-ac37-ca4df69c5a3a /media/paul/Television auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/744EFFFF3AFEC7C9 /media/paul/Downloads auto nosuid,nodev,nofail,x-gvfs-show,uid=1000,gid=1000,umask=0022,rw 0 0

Where the problem drive is listed last (uuid=744EFFFF3AFEC7C9)

Please help me before I throw my computer out of my bedroom window

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.