2

today, my NVidia graphics card gave up. I removed it from my computer and switched to the on-board one:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

I have two systems on this computer: One is Kubuntu 15.04 which used the nouveau driver, before (and never used the proprietary nvidia driver). The other one is a Kubuntu 15.10 which used the proprietary nvidia-352 driver before.

After the removal of the NVidia driver, my Kubuntu 15.04 booted without any trouble and X works fine with two monitors attached and with all 3D effects. I really do not need an NVidia card.

However, the Kubuntu 15.10 does not work properly. First, X didn't start at all. So I logged in to the text console (which was fortunately working fine) and I uninstalled all nvidia driver stuff:

$ apt-get purge nvidia-*

After this, I rebooted and the system still didn't work :-( I found out that the problem was a wrong 'xorg.conf'. It stated (among other things):

Section "ServerLayout"
    Identifier "layout" 
    Screen 0 "nvidia"   
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

I removed the 'Inactive "intel"' line, changed the "nvidia" to "intel" and invoked startx => got a graphical system. I rebooted and the file was wrong again.

After some digging, I found that I have to pass 'nogpumanager' to the kernel, hence I edited '/etc/default/grub', ran 'update-grub' and rebooted => the system booted fine.

However, I saw that some of the desktop effects - e.g. the cube - don't work (they work fine in my Kubuntu 15.04).

The problem seems to be that X uses the 'modesetting' driver instead of the 'intel' driver. I tried to explicitly set 'Driver "intel"' in my 'xorg.conf', but then X does not start :-(

When I run 'Xorg -configure', however, it lists 'intel' as the first line under 'List of video drivers:'!

I assume that my previous installation of the nvidia proprietary driver somehow somewhere forced the intel driver out of the way. However, even after hours of searching, I still didn't find where this problem is located.

In which file does it suppress the intel driver?!

Please help! I really don't want to re-install the system, just because the nvidia driver left some garbage behind (that I was unable to find, so far). And I really would like to use the cube and many other 3D effects again ;-) They seem to be automatically suppressed when using XRender (instead of OpenGL). And I seem not to be able to enable OpenGL when not using the proper driver, even though 'glxinfo' says:

$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)
OpenGL version string: 3.0 Mesa 11.0.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

Also, test programs like 'glxgears' work fine (and even say, I had 2500+ FPS).

Best regards, Marco :-)

2

Yabbadabbadoooo!!!! Yeah, I found + fixed it!!!

I figured this problem might somehow be related to the 'alternatives' and after a bit more research, I stumbled over this:

sudo update-alternatives --remove-all x86_64-linux-gnu_gl_conf
sudo update-alternatives --remove-all i386-linux-gnu_gl_conf

http://forum.ubuntuusers.de/topic/nvidia-current-update-problem/ (at the end) https://github.com/Bumblebee-Project/Bumblebee/issues/76

To be sure, I additionally ran this:

sudo update-alternatives --remove-all gl_conf

...but this alternative seemed to have not been assigned.

I then removed my '/etc/X11/xorg.conf' again, removed the kernel option 'nogpumanager' from '/etc/default/grub' (followed by 'update-grub') and rebooted.

...and it works fine, now!

Here's (an excerpt of) the output of 'glxinfo':

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.0.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

With the intel driver now being active, I was able to switch from 'XRender' to 'OpenGL 3.1' (in the display settings under 'Compositor') and all 3D effects work again.

Edit: One day later, I saw that LibreOffice didn't start, anymore. I don't have the exact error message anymore, but it said sth. about a missing library - looking related to this problem (and it worked fine before removing NVidia).

After some research, I did the following:

sudo apt-get install --reinstall libglu1-mesa libglu1-mesa:i386
sudo apt-get install --reinstall libglu1
sudo apt-get install --reinstall libgl1-mesa-glx

I think, only the last line is relevant, but I'm listing all for completeness.

|improve this answer|||||
  • Thank you marco, I have a similar setup (well same graphics card, same version of Kubuntu, some similar issues). Your post was helpful. I just wanted to add, have you tried the Intel Graphics Installer? 01.org/linuxgraphics/downloads/… – Adam Plocher Jan 21 '16 at 22:39
  • No, I did not try to install anything manually (including this Intel Graphics Installer). I only did the 'update-alternatives' + 'apt-get install' commands documented in my post. And since everything is working fine, I don't really want to try it out - have enough coding to do ;-) – marco Jan 22 '16 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.