1

I need to use Linux 3, becasue with Linux 2.6.x has display problems with my SandyBridge integrated graphic. On the other hand, I need to downgrade to Ubuntu 10.04/10 because Betavine packages for running my mobile broadband modem work only with Ubuntu 10.04 (and 10.10). Hence I need to make a compromise. I appreciate your hints.

3
  • Sandy bridge works OK on the natty kernel - if you start from 10.04 - you can use this answer here to upgrade graphics and the kernel to work with your sandybridge laptop. askubuntu.com/questions/58376/…
    – fossfreedom
    Oct 24, 2011 at 19:49
  • 1
    FYI, the difference from 2.6.x to 3.0.0 is nothing. It was just a version bump from Linus =P
    – Chuck R
    Feb 20, 2012 at 16:23
  • I have 3.2.4 installed in Natty I just went to the mainline and downloaded the .DEBs
    – Ringtail
    Mar 10, 2012 at 17:21

2 Answers 2

1

Or, as a last-ditch effort you could compile a new kernel from kernel.org and use that.

To get an ubuntu-styled kernel:

apt-get source linux-image-$(uname -r)
cd linux-image-$(uname -r)
make menuconfig #Then hit exit and save the configuration
cd ..
wget http://www.kernel.org/pub/linux/kernel/v3.0/linux-3.2.6.tar.bz2
tar -xjf linux-3.2.6.tar.bz2
cd linux-3.2.6
make menuconfig
cp ../linux-image-$(uname -r)/.config .
rm -R ../linux-image-$(uname -r)*
make
make install
-1

Maybe. There is an Ubuntu kernel PPA: https://launchpad.net/~kernel-ppa/+archive/ppa

You can try download the Linux kernel 3 for Oneiric, maybe it will work. http://kernel.ubuntu.com/~kernel-ppa/mainline/

1
  • you can't use a oneiric kernel for a Ubuntu versions that's not Oneiric!
    – Alvar
    Feb 20, 2012 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.