2

I have download teamviewer.deb and click on it . It opened in Ubuntu Software center. And it shows the error

 cant install libc6:i386 

so i found this below command and i tried it on terminal.

  sudo apt-get install libc6-amd64 libc6

but it shows some error.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
 or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libc6-amd64:i386 : Depends: libc6:i386 (= 2.19-0ubuntu6) but it is not       going to be installed
 E: Unable to correct problems, you have held broken packages.

any helps to solve and install teamviewer on my ubuntu 14.04 lts

Note : I have already read this articles. But no helps.

libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed (on 14.04.2 64-bit)

still i am getting this error

varadha@varadha-X551CAP:~$ sudo dpkg --add-architecture i386
 varadha@varadha-X551CAP:~$ sudo apt-get -f install
  Reading package lists... Done
 Building dependency tree       
 Reading state information... Done
 The following packages were automatically installed and are no longer     required:
 efibootmgr libtimezonemap1 secureboot-db
Use 'apt-get autoremove' to remove them.
 0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
  • I guess you have 64bit Ubuntu ? right ? Add the 32bit architecture to your system sudo dpkg --add-architecture i386 now the packages can be installed ? – Mark Kirby Dec 7 '15 at 9:59
  • sudo apt-get -f install if you keep getting you have held broken packages – Mark Kirby Dec 7 '15 at 10:38
  • That edit does not show an error, just says some packages are not needed, remove them with sudo apt-get autoremove or don't does not matter. Now you can sudo apt-get install libc6:i386 then install teamviewer again, – Mark Kirby Dec 7 '15 at 11:03
-1

I had the same problem, too. Please check your repositories in source list, because my wrong is put repositories ubuntu 14.04 for my ubuntu 15.04. Now, I have solved my problem.

  • Thank you for your solution. Actually i have upgraded my Ubuntu than it was solved automatically. But I dont know the reason. So i didnt answer or reply this question. – Kvvaradha Apr 13 '16 at 9:37
1

Are you on Ubuntu 64 bits or 32 bits ? Have you downloaded Teamviewer 64 bits or 32 bits ?

In my case, when I was under Ubuntu 14.04 64 bits, I remember that I had to use TeamViewer 32 bit for making it working.

  • from the site itself common pack for both systems. – Kvvaradha Dec 7 '15 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.