2

I am controlling my robot from my laptop. The robot itself has its own laptop and is broadcasting an adhoc access point. I noticed that the speed between both laptops is really limited and peaks at around 60 KB/sec. Both computers are using Ubuntu 14.04

Is such a speed normal or is there any problem behind that? And is there any live logging for the wireless adapter where eventual problems can be observed?

  • How did you set up the WiFi hotspot?. Also, here's a tip: The robot having the hotspot is really convenient but it running of battery it dies really quickly... – Wilf Dec 6 '15 at 21:02
  • Just the normal way in Ubuntu with network manager GUI. – Mehdi Dec 6 '15 at 21:03
1

You could try making a AP hotspot, e.g. using a script called ap-hotspot (infrastructure Access Points can be more reliable):

To set up a simple wifi hotpsot for Android and other devices, you can use ap-hotspot as detailed here. Basically, install it:

sudo add-apt-repository ppa:nilarimogard/webupd8

Press Enter to confirm this - then run these to actually install it:

sudo apt-get update
sudo apt-get install ap-hotspot

Use ppa's at your own not-very-high risk - note you need to add the PPA and run the update command before you are able to install it.
Start it with:

sudo ap-hotspot start

You can also stop it:

sudo ap-hotspot stop

and configure it:

sudo ap-hotspot configure

Ubuntu 14.04 needs a special fix as well - plz see the big note at end of this post:

For Ubuntu 14.04:

also the hostapd version in Ubuntu 14.04 is buggy and doesn't work properly. To get AP-Hotspot to work with hostapd in Ubuntu 14.04, you need to downgrade hostapd and use apt to hold the package so it's not upgraded (thanks to spupuz for the tip!). To do this, use the following commands:

64bit:

cd /tmp
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_amd64.deb
sudo dpkg -i hostapd*.deb
sudo apt-mark hold hostapd

32bit:

cd /tmp
wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_i386.deb
sudo dpkg -i hostapd*.deb
sudo apt-mark hold hostapd

If you want to update hostapd you need to unhold the package - ap-hotspot won't work anymore though.

Big Note: ap-hotspot is out of date and not really maintained anymore - as far as I can tell it should work on Linux OSs based on Debian Wheezy, and on 14.04 with above workaround (which uses a old version, which isn't great for varying reasons) - however I do know it seems to work very well on varying hardware.

There are alternatives (e.g. create_ap) - also you can use the variety of instructions here - you could also try setting the mode to infrastructure in the 'Network Connections' settings (this may be the default with newer versions of Gnome/NetworkManager):

enter image description here

  • Come on everybody knows what a mac address is :D – Mehdi Dec 6 '15 at 23:11
  • 1
    Yeah I know :-) Simplifying things can help sometimes – Wilf Dec 6 '15 at 23:37
0

It seems to be a weird hardware problem. I switched my setup by creating an Adhoc access point from my working laptop and let the robot's laptop connect on it. And everything worked well.

Robot's laptop is an old x220 lenovo. My laptop is a more recent T430 lenovo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.