0

I'm using Ubuntu 14.04 with unity, and I know that Touchegg is not compatible with unity. But according to these instructions, some people say that worked for them with unity.

I am trying these instructions to disable unity's default trackpad gestures, and I guess that after some updates, some file types of the unity building packages have been changed.

When I do:

cd /tmp/unity/unity-*
dpkg-buildpackage -us -uc -nc
cd ..
sudo dpkg -i *deb
sudo apt-get -f install
sudo apt-get autoremove

I see there aren't any *deb files in the containing file.

My question is how to rebuild these edited unity.

These are the files under the file "Unity":

unity-7.2.6+14.04.20151021
unity_7.2.6+14.04.20151021-0ubuntu1.diff.gz
unity_7.2.6+14.04.20151021-0ubuntu1.dsc
unity_7.2.6+14.04.20151021.orig.tar.gz
1

There is also Ginn, which according to the ubuntu wiki is compatible with unity.

This article from August 2014 compares the three options: Ginn, xSwipe, and TouchEgg. Things might have changed since then. I haven't had the chance to test any of them yet.

| improve this answer | |
0

Although the TouchEgg seems like the only option, there is another trackpad application named "xSwipe". It's compatible with both unity and gnome and it works like a charm. No need to dealing with unity rebuilding!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.