I tried to install LAMP server using tasksel. But it shows the following error message. I tried changing permissions using chmod but in vain

debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied
debconf: DbDriver "config": could not write /var/cache/debconf/config.dat-new: Permission denied
tasksel: debconf failed to run

How can it be resolved?

  • Edit your question and add the used command to install LAMP and the used chmod command.
    – A.B.
    Dec 6, 2015 at 18:09
  • i just typed tasksel and selected LAMP server and pressed tab and enter. the result is the following error messages.
    – Sarath
    Dec 6, 2015 at 18:25
  • With our without sudo?
    – A.B.
    Dec 6, 2015 at 18:26
  • without sudo. le me try with sudo
    – Sarath
    Dec 6, 2015 at 18:45

1 Answer 1


Each system-wide installation needs root-rights. Run

sudo tasksel

and make your choice or run

sudo tasksel install lamp-server

to install LAMP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.