4

Today when I started gnome-terminal, the menu bar was not integrated into the title bar as usually. Only the Terminal menu point is correctly integrated, all others show up in a separate menu bar.

The Unity setting for that seems still correct and it works also e.g. for Firefox and others.

image

If I untick the Show Menubar option, I lose the menu entirely, just the Terminal menu point is still there and still correctly integrated into the title bar. All other menu points are gone.

image

Right-clicking the title bar just brings the normal context menu:

image

This is not an issue when operating on the guest account! It works perfectly well there and shows all menu points correctly integrated into either the title bar or the panel, depending on the setting.

What is the problem here and how can I fix the menu-into-title-bar-integration again?

I'm using Ubuntu 15.10 with Unity 7.3.2 and gnome-terminal 3.16.2-1ubuntu4.

  • Have you tried right-clicking the title bar? I believe that brings up the relevant option, but I'm not sure. – kos Dec 6 '15 at 16:16
  • @kos Nothing unusual when right-clicking the title bar... See my edit (added 3rd picture), please. – Byte Commander Dec 6 '15 at 16:36
  • Is this option enabled? cdn5.howtogeek.com/wp-content/uploads/2014/04/… – kos Dec 6 '15 at 16:45
  • @kos Yes, it is. I just checked it and set it to "menu bar" and back to "window's title bar" again. It did not change anything, but it would only have moved the menu from the window's title bar to the panel anyway. It should not toggle showing a separate menu bar. – Byte Commander Dec 6 '15 at 16:54
  • 1
    @kos Don't ask me why, but the default error solving method for Windows systems (REBOOT) did the trick... :P – Byte Commander Dec 6 '15 at 17:18
0

I have no idea why and appreciate any other answer that might shed some more light on this, but I could solve this problem simply...

... by rebooting!

Maybe logging out and back in or restarting the Unity desktop environment would have solved it as well, I can't tell you because I did not try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.