5

I have an external USB drive connected to my Ubuntu 12.04.5 server, which has been formatted with exFAT filesystem (after I installed the required packages like fuse-exfat and exfat-util). My drive works perfectly without any issue.

But when I try to connect this drive to a Windows 10 host, it is not recognized properly by the system (Windows is not able to detect the filesystem). I have read somewhere that the same happens if the drive has been formatted from a Mac, and the "only" solution was to always format a drive from Windows, if you want to use it on other operating systems.

Am I the only one experimenting this? Is it because I made sure to create an "aligned" partition when I formatted it (no remember exactly what it was, but I did to get rid of a warning in Ubuntu when I mount it).

Update (2015-12-07)

The version of exfat-utils and exfat-fuse: 1.0.1-1~ubuntu12.04.1.

And the warning I got wasn't on mount after all, but at the creation of the partition using parted with mkpart:

Warning: The resulting partition is not properly aligned for best performance.

So I followed this guide to create an aligned partition: http://rainbow.chard.org/2013/01/30/how-to-align-partitions-for-best-performance-using-parted/

  • 1
    12.04 may still be using a old version of the exFAT drivers (thye were probably backported to it), so formatting the drive on a newer version of Ubuntu/Linux etc may work better. What errors are you getting if any, and how did you 'align', format it etc? – Wilf Dec 6 '15 at 15:43
  • 1
    Given that the issue here is in a Windows 10 environment this belongs on Super User, not Ask Ubuntu – Thomas Ward Dec 6 '15 at 16:16
  • Maybe my question was not clear, but if I'm the only one experimenting this problem, then it's an issue on how I formatted my drive with exFAT on Ubuntu, so I do believe my post belong here. – dbernard Dec 7 '15 at 15:50
  • @Wilf, I updated my post with more information. From what I see in packages.ubuntu.com/trusty/exfat-fuse, Ubuntu 14.04 has the same exfat version than mine. – dbernard Dec 7 '15 at 16:15
  • Sorry but this question does not fit AskUbuntu. You should ask it in Windows 10 support, since the problem is in Windows, not Ubuntu. Also remember to take note of every warning/error you get when dealing with OSs. They may be important while solving your problem. You should try to backup any important files and reformat your drive. This never happened to me when I had Windows: I simply formatted my flash drives and they worked in both Ubuntu and Windows (I use only Arch Linux now). – Eduardo Cola Dec 7 '15 at 20:42
2

After some trial and errors, I've been able to format an exFAT partition on Ubuntu that is working on Windows 10. The trick is to add the msftdata flag on the partition (regardless if partition is aligned or not):

 sudo parted <DEVICE> set <PARTITION_NUMBER> msftdata on

For example:

 sudo parted /dev/sde set 1 msftdata on

And it worked for me in Windows 10!

And in case it helps someone, this is how I created a single aligned exFAT partition in the first place:

 sudo parted /dev/sde mklabel gpt
 sudo parted -a optimal /dev/sde mkpart primary '0%' '100%'
 sudo mkfs.exfat /dev/sde1
  • 1
    Would it work to set the msftdata flag after I've formatted the partition? I don't want to reformat and lose my data. – Francois Botha Dec 8 '17 at 10:50
  • The command didn't work for me. Maybe it's only for GPT disks, not MBR? sudo parted /dev/sdb set 1 msftdata on gave me: "invalid token: msftdata" and "Flag to Invert?". – mivk Feb 1 '18 at 11:54
  • @mivk, yes as per the gparted manual, it's only for GPT: gnu.org/software/parted/manual/html_node/set.html – dbernard Feb 1 '18 at 13:35
1

I have the same problem with Ubuntu 14.04 LTS So I ended up with formatting 2TB HDD under Windows 10 so I did't bother trying different block sizes or other format parameters. I have read similar article about MacOS X From Apple forum: https://discussions.apple.com/thread/4745362?tstart=0

I heard somewhere that if a External Hard Drive is formated exFat on a Mac, it wont work on Windows, unless it is Mac OS X 10.7 (Lion) or 10.8 (Mountain Lion). I have Snow Leopard (10.6.8) and I wanted to know if I format my External HD for exFat will it work on Windows? I currently have is formatted as Fat32 but there is a 4GB limit so I wanted to try exFat.

It's a known issue that, depending on how big the drive is, formatting exFAT in OS X uses too large of block (cluster) size that Windows doesn't like. Format the drive from within Windows with a block size no larger than 1024 and you should be able to use the drive on both platforms.

So it seams that IT IS UBUNTU PROBLEM and FITS AskUbuntu because of using by default nonstandard or incompatible block size while formatting exFATpartition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.